Anyone else seeing a performance hit since last update?


Shapr3D updated this morning to the latest update, I am not sure if this was just released or if it is a bit older as I haven’t looked at the details of the update just yet. Prior to the update I had no performance issues with the app.

However I am running it on an iPad Pro 12.9 with no other apps running at all other than what is required by the iPad. I am working on a new sketch which has lots of constraints but overall a simple sketch. I haven’t started extruding yet.

I am seeing a huge lag with the app and some of the constraints. In some cases it is taking 5-10 seconds to respond. Will large amounts of constraints cause a performance issue with Shapr3D? This sketch is by far using the most constraints of any other that I have completed so far.

I had to take a break as I have been at it for awhile, but when I go back to it I will try rebooting the iPad to see if it just needs to be refreshed.


Could, but shouldn’t. Is the same sketch worked fine with the previous version? Can you share the file? I would like to debug the problem.


Hi Istvan, I just emailed you the file. Thanks for taking a look. It could be just my iPad needing a reboot but I’m not certain as this didn’t have issues yesterday before the update.


Haven’t been feeling any slowdown personally
The wire frame issue is still popping up!


I just wanted to give a quick update here. Rebooting the iPad didn’t solve the issue.

I worked with this some last night for a couple hours. It seems that it was/is related to the constraints in some way, I haven’t figured out how though. But what I did was delete about half the constraints and the issue went away. I then added the constraints again and it seems that the issue went away.

I was able to get the sketch into a rough first draft and completed a test print with the Makerbot Replicator+.

I just wanted to share my findings to see if it helps. Istvan, if you do not see anything obvious with the file I sent you I wouldn’t spend to much time on it since I have it working again. But it still may be worth a look, obviously if you see something either from the app site or even from the way I am using it, it would be helpful to know.


I am debugging this. Will update you ASAP.


Issue fixed. It will be included in the next release, thanks for reporting the problem.


But if this is a major issue for you, we can add you to the 2.2 (colors) beta, and include the fix to the next beta build.


Hi Istvan, I am glad that you found the issue and it was something that can be corrected this quickly.

It isn’t a major issue as I got past it last night, however if you wish to add the fix to the beta and want to add me to the beta I would be happy to work with it.


Awesome, I will add some additional fixes regarding this problem, and then I will add you to the beta.


The performance hit has come back. It has me at a dead standstill with the sketch I’m working on. Any update on when the fix can be applied? It went away for a bit, but I’d now back.


I deleted the file and started over. Since the left and right of the sketch are a mirror image I sketched only 50% of the part. I then extruded it, mirrored it and the used the union feature. The part looks right, I will print it tomorrow and test fit the electronics.


Came back? Did you try it withthe beta?


I haven’t received the invite for the beta to give it a try.


Hwo about now? Check your mail plz


I just got the invite. I will backup the iPad and install it this morning and do some testing with it. Thank you for the invite.


The beta has been installed. Colors are working as expected and so far no performance issue is seen. I will be working on another sketch later this morning after I test print the one I completed last night, it will be very similar to the one that had the performance issues.

But as I stated so far all is good. Thanks again for finding the issue and implementing a fix so quickly.

Here is a quick screenshot of some workspaces using the colors feature.