Beta going critical

New release is now SUPER unstable on 2020 IPad Pro, definitely NOT ready. Crashing constantly. Doesn’t seem to correspond to any particular routine, does it in both draft and visualization. Interestingly it seems to reopen to the most current step, so no work is lost. Wouldn’t matter anyway, it’s a Beta, I expect problems. We’ve asked the question in the open but nobody has commented on why this version isn’t generating crash reports.

1 Like

Could you share the problematic workspace? I would try to investigate if there is something specific to that one.


Could you try the new beta, Crash fixes - 5.150 (3279) and let us know if you are still crashing?

1 Like

For me nothing changed, since the last three version, one of workspace crash when I like to open.
The models was draw in the closed beta, works well, till the ~140 version came.
Already uploaded it.

Device: Ipad pro 12,9 2018
Ios: 15.5

Did you go through the recovery process for the crashing workspace?

Long story short, if it was created in 5.120 (3045), it will always crash. To save it, you have to install the 5.120 version from testflight, export it in x_t format, update the app, import it back. It will loose the sketches and the assigned materials though.

There’s nothing really to point at, it was any model out a dozen or more, any tool or process. I gave the new beta loaded, appears to be opening files from previous versions fine. See how it goes.

1 Like #a67c5251

Ok, first crash in this version. Happened as I was switching to Viz mode, had made a geometry change after previous look in Viz. not a complex model with only one material added. Still no crash report opening up. If it helps for comparison, I have another project going where I am placing objects each made in their own workspace and then brought together in one scene. It has over 20 materials with over 30 settings total, doesn’t seem to crash any more often despite the workload. In fact it rotates and pans just as smoothly as a much simpler workspace.

1 Like

Could you upload the workspace you are having trouble with?

Sure, upload to where?

Anything works, if not confidential, could be Gdrive or iCloud and you can share the link here, or you can send it as attachment directly to my email at

Ok I’m dropping out of the Beta. The latest update is unusable, I’ve crashed every three minutes the last hour. I don’t know if maybe you guys are optimizing for the M1? The further along we move, the worse it gets. Can’t operate with this.

1 Like

We don’t optimise to any specific chip.

1 Like

Yes, it is crashing like hell. Can not even do a small task on it now. And also whenever I tries to share my file to work on some other software it crashes…. Its like I can’t even resume my work until this crash thing stops. Beta is becoming worse and worse.

Could you share the problematic workspace so we can investigate? OS version, and the device being used, and steps where you run into the crash could also help.

After your suggestion, I can open that workspace, only one body lost It easy to draw again.
But most of crashes when tap a plane, face. The model not difficult

1 Like

Could you make a short video which shows how / when it happens?

I tried to reconstruct the problem. It also succeeded but after the crash the screenshot was not recorded. Only back to the main screen.
The workspace is a simple furniture.

I send a mail with the workspace, with some comments

1 Like

There is no particular step… it crash anytime. It crashes while sharing file as well of which the screenshot is shared below.
OS: iPad OS 15.5

It looks like the known iOS share bug.

1 Like