Exporting HQ STL issues last 2 days


I started having issues as of last night exporting High Quality STL files, I’m not having issues with importing though. Last night I tried to export one of my workspaces as a HQ STL and it just sat there so I aborted the export and used medium quality.

This morning I attempted to export one of the groups from the same model as a HQ STL for 3D printing and it sat there for a while then Shapr3D crashed/closed.

Exporting to shapr/stp and medium quality STL has no issues.

Any thoughts?


Can you share one of the workspaces that you had issues with? istvan@shapr3d.com, in .shapr format please.


Sure thing. I have sent it over to you.


Hi Istvan, I was wondering if you found anything with that workspace I sent you that would be causing the issue?

I had no internet since yesterday do to a storm so I couldn’t ask sooner.

I had major issues today, parts deleted, performance issues as well as whole workspace disappearing during a crash. I am starting to think it may be my iPad since I don’t see others having the same issue. I don’t use the iPad for anything but Shapr3D. In fact I did a full reset of the iPad to be sure only factory installed apps are there. But I am having complete random freezes with the App, but I am not confident its the app now as I mentioned.


Yes, we did find the cause of the STL issue. Can you provide more info on when these hangs/crashes occur? During sketching, using a tool, pushing/pulling faces, etc.?


Disappearing workspace issue is extremely weird, if you can provide any more detail about it that would be much appreciated.


It doesn’t matter what I am doing within the app. I could be sketching, extruding or using any tool. It’s completely random.

When it happens it hangs for 10-20 seconds before responding again. Then it will run fine for 30 minutes maybe even an hour or sometimes just 5 minutes.

I really wish I could be more specific but there is no patter to how or why this is happening.


As for the disappearing workspace, it only happens when the app hangs then is filled by a sudden app closure. The workspace will do one of two things, either fully disappear or delete all parts and sketches and open blank.

Again, no specific action is causing it that I can see. It just happens as described above.

I’m starting to believe it’s the iPad.


So “only” the contents of the workspace disappear, not the file itself?


Yes, just the contents.


If it helps any, it’s the same workspace I sent you. Thankfully I have several copies and revisions. So I only lose what I was working on at the time before saving again.


I am horribly sorry about that. I know that this does not help too much, but we are working on a huge (super secret) thing that will fix all of these problems. You will get early access of course :slight_smile: As soon as possible.


No worries. I fully understand all of what is happen as well as I am using beta software. And this is part of the testing. I test software all the time for my work as well as for many vendors.

I am not trying to complain but rather share what I am seeing hoping that either its a known issue or one that will shed light on other issues.

I am ready to help test when ever you need new updates tested.


I am going to upload a new build in an hour, that might going to fix these problems.


I uploaded a new build, it does not solve the HQ STL issue, but might going to solve others. Let me know how it worked for you.


I do not see a new build in TestFlight, is there another way I am supposed to download it?


Oh no… Stupid iTunesConnect. I have to do everything manually, you should see the build now.


I do, thank you. Installing now.

I have a couple hours of modeling to do today as I am remodeling the body of the bot. So it will get used quite a bit.

I’m not sure when I will do it but it will be today. I will keep you posted.


Well, I have had a chance to play around with it for about 5-6 hours. Performance is only slightly better, I can’t complete my last part as the performance is all over the place. Trimming sketches seems to hang nearly every time. Extruding parts as simple as squares is causing artifacts and extruding as if it is hollow at times.

To be sure it wasn’t my sketch I deleted it and tried a second time and got the same results.

Either my iPad is junk, or my sketching is horribly wrong somewhere that I can’t seem to see it or I have hit the limit with this workspace performance wise (same one I sent you).

In either case it has me frustrated so I need to step back from it for a couple hours or potentially the rest of the day. I haven’t made any progress during this time frame. I have nothing to show as to why it happens it is completely random.

I will import the SHAPR file into a new workspace and delete all parts except the one I am working on, this should tell me if it is possible I hit the level the iPad can handle or maybe the app. I wouldn’t think this would be the issue since all parts are hidden with the exception of the one I am working on, the screen doesn’t have to render/draw them.

Its completely weird, odd and has me lost as to the cause.


I’m happy to report the latest build seems to have fixed the issues. Performance is much better and the artifacts I was getting during extrusion no longer exist.

All I did was close the app, install the new one and extrude the sketch that was already there. The issues with it hanging while using the trim feature appear to be gone.

Thank you for whatever it was that you guys did to fix this.