Step import file size limitation/bug


#1

Is there a file size limitation for the importing of step files? I have several that are 20 MB or more. These were created in Shapr3D each in a fresh workspace, now trying to import them into one workspace isn’t possible. I choose the file to import and it just hangs as if it’s doing something.

I’ve let it sit for more than one hour just to see what happens. I have tried importing into existing workspaces, new workspaces and even the one it was created in. But get the same results.

I have powered down/rebooted the iPad multiple times with no success. I can import and export smaller files withou issue. It don’t matter what workspace I use, new or existing.

I can export into smaller files and do it that way. I even tried exporting my whole model which ends up being 400+ MB in size, this will not import either.


#2

I have narrowed it down to two things.

  • Parts that have threads - cause of file size

  • File size under 5 MB seems to work

I had to split my parts into 8 exports in order to bring it all into the workspace.

FEATURE REQUEST - Merge two different workspaces into one. This would likely eliminate the issue I am seeing. I frequently work a portion of a model in a different workspace to avoid accidental changes to work that is near final result.