Union Process deleting parts


#1

When using the union process I select 3 parts then when complete 1 remains and two are deleted. Here is a short video, this is unlisted and only available here.

Any ideas why this would happen? I was able to do this in the past but today I cannot. It it matters I am using the latest beta of the app.


#2

Unfortunately it is not your fault, it is a bug. Caused by the 3d geometry kernel in Shapr, that is going to be replaced soon. Remodeling the parts might help :frowning:


#3

Thanks for the quick reply.

The app just crashed and deleted the parts. So I am forced into recreating as I hadn’t saved them yet. :slightly_frowning_face:


#4

Sorry about that, we are working on a big project that will eliminate all of these issues.


#5

No worries, everything prior is saved and backed up in 4 locations so no major loss.


#6

Remodeling the parts solved the issue with using the union feature. Maybe something was wrong with the way I initially modeled the parts, but that issue is now solved.

Just thought I would share an update. You can see the printed parts in the share your creation thread.


#7

Hey @roboticshobbyist,

How you add the pencil input when recording the iPad screen?

Thanks a lot,

theepicapple1


#8

Here you go. I hope this helps.


#9

Thanks so much that’s really helpful, I would’ve never found that myself!

Btw what you do is really amazing! (I read your website)


#10

Hi Istvan,

I am one of OpenCascade developers. It is a pity to know that you are getting rid of OpenCascade. Can you share your thoughts? Did it perform so bad? Or was it functionally poor (like you miss direct modeling, whatever)? Any ideas on what theoretically could be done to make it acceptable in your project?

I am not a sales guy, and I am not going to promote or defend our kernel here. Just curious if we could improve it and in which directions.

BTW, we are quite impressed by what you’re doing in Shapr3D. Thank you for all your contributions and giving OCCT a try.

Thanks.


#11

Hey,

I would be happy to share my thoughts in email - istvan@shapr3d.com

Cheers,