Workspace recovery after crash?


#1

I was working on my helicopter project with many changes that haven’t been saved yet. I typically save each day after I am complete.

While moving a part with the transform menu, Shapr3D crashed. Now the workspace will not open. Is there a way to recover it, or did I really lose 10.5 hours of work today?

I can’t save it as a SHAPR FILE as I can’t open it. My last save was 29 hours ago. If there is no way to recover it, then lots of work is lost. I typically save more frequently but I was on a roll with the work so I was waiting for the final alignment of the parts, then I was going to save. I was nearly done.

Hoping there is a way. Here is a video of what it does when I attempt to open it.


#2

Looks like I saved most all the parts individually, so I imported yesterday’s backup and I am importing the files. Looks like possibly only one item was lost and it appears to be the most basic of them all, so all in all it’s just an inconvenience rather than a loss of work.

Is there a user viewable log that I can look at?


#3

By connecting your iPad to your computer you can download the file through iTunes. It would be great if you could share it.


#4

@Istvan_Shapr3D I just sent you a direct message with the link to the files recovered from iTunes.

Thanks in advance for looking at this. However, other than understanding the reason, I don’t need the workspace as I recreated most of it from individually saved step files.


#5

By chance were you able to look at the workspace and determine the cause of the crash?

I ask because it just happened again. I worked most of the morning, I saved the workspace at 2:45 PM EST. Then I worked for 3-4 hours more without saving as I was just about complete with another section. The app crashed while doing a simple revolve. When it came back 95% of my model was missing.

In short I loaded the saved workspace, but lost the last 3 hours of work. I’m afraid to do anymore now. This has become very unreliable for some reason. Any thoughts?


#6

Interesting, after a restart of the iPad part of the workspace came back, but many parts that were hollow became solids.

I deleted all the defective parts, saved the good parts as step files and then deleted the workspace. I then opened a new workspace from the Backups I have been making, then imported the step files I was able to save off. I got most all my work back, but I shouldn’t have to keep using these types of workarounds.

By chance could my model with over 500 parts and nearly 275 MB in size be the issue? Could I be hitting a limitation with either parts count or file size?


#7

This evening it crashed a third time. This time no bodies / parts were lost and the workspace opened right back up.

But when it opened up I got a message that some sketches may not be available. In this case this isn’t an issue as there are so many sketches I wouldn’t remember them all anyways unless it was the one I was working on.

Since I have upgraded to the latest release (3.5.5) I have had 3 crashes. When I was on 3.5.4 I didn’t have any crashes that I can recall. Not sure if there is a relation or not. But I want to try and provide as much feedback on these incidents as possible.


#8

One of our developers is investigatibg this already. Sorry for the inconvenience, we will fix this ASAP.


#9

Thank You. Looking forward to a solution. I have tried to use Shapr3D today and export some parts in Step Format. Just simply exporting nothing more, the app has crashed 3 times. It has become highly unreliable all of a sudden.