Where is revolve?

Hello guys, I have the early access version,


I don’t know why but I can’t use SUBTRACT, INTERSECT, REVOLVE, SWEEP, as in the iPad version, this is Windows 10, the device is Lenovo Yoga 6, I hope you can fix this issue, thanks a lot in advance!!

I’m guessing you have an object selected in addition to the sketch. Try unselecting everything and only selecting the sketch profile you want to revolve.

thanks for the answer, but unfortunately there’s no selection…

Create a sketch on a plane. Z axis for example, next roll to front view, or something that makes it flat and you have to draw an axis to revolve around, or select it if you made it at the home point. So tap your body to select it, then tap the axis that you made and when you tap the axis, it should change your options and allow you to revolve around that axis. In the learn section, Create Complex Bodies, the first example is revolve. Hope this helps.


Well actually this button doesn’t appear and as you can see I selected only the section and the rotation axis.
I don’t know why the SUBTRACT, INTERSECT, REVOLVE, SWEEP doesn’t appear even if I open an empty file… I can only use OFFSET FACE, CHAMFER/FILLET, EXTRUDE, SHELL, LOFT, UNION from Tools section…

Hey – you could try one more thing. There’s a supper annoying bug (with a fix is on the way!) which makes tools/actions simply disappear from the end of the list if the vertical resolution is too low instead of being hidden behind a “more” selector. You could try making the app full-screen by using the small squircle icon in the bottom-right corner of the window. It would hide the taskbar and gain you a few additional pixels which might make the tools you need show up. Also, as others suggested, selecting the relevant objects first would narrow down the list of available actions, making sure that the one you need fits onto the screen.

Well I tried your suggestion, but it just appear SUBTRACT, but I don’t need to use it for now.

Hi @Gatto_gattez! In your last screenshot, all the sketch curves (even the outlines of the cross-sections) and the axis-line also selected. The cross-section cannot be revolved with the contour curves, this is why the tool is not given in the list. You should only select the enclosed area and the axis to revolve around.

I assume you have selected everything at once with the lasso tool. Please note that the lasso tool has a selection filter option, where you can set it to select faces only. This will let you select the enclosed area only, after that you can select the axis and you will have the Revolve tool given :slight_smile:

Here is a short video about the solution, please note the selection filter on the left side while dragging the lasso, there is the same filter on Windows also. In the beginning of the video I made a selection without filtering, there you can see the same tools were given just as in your case. Sorry for the iPad UI, Windows acts like the same.

Okay, but it doesn’t work, if I open the ‘tools’ palette there are some tools missing… But if I open the ‘tools’ I nave to dee all the buttons including the ones I wrote before…