Why I can’t shell this loft object please help

I include the project file as a link. Can anyone tell me why I can’t shell this object with 1mm thickness. thanksObject

I can’t view it. Do you need OnShape to see it?
Can you share some screen pics, or the Shapr3D file?

sorry. the mail system said that the file too big to upload. do you have other mail address that i can send the sharpr3d poject file to you? thanks. i really need help.

Can you post a couple of screen grabs of the body you want to shell?

@Bradley
I have found with Lofts where an End Face is beyond a particular angle Shell does not function.
Can it be assumed that you have made several attempts to Shell the Lofted Body?
Is the Circular Plane at an angle to the other Planes?
Have you tried Shell from the Circular Plane?

In the following shapr.File the Leftmost Image Top Face is at 10º and will not accept Shell from either end.
EDIT: The above statement has proven not to be true every time. Revisiting the same file the Shell was found to be successful. The oddities with the Bodies created have been made known to the S3D Team, this aspect may be cleared up at the same time?
The Middle Image is at 5º and accespts Shell from either end. Use the stacked Planes to experiment.

LoftNilShell.shapr (340 KB)

If this does not help may I sugest to download your shapr. File to Dropbox and publish the Link to enable us to access it here?

Did you try to maybe offset the angles of your current shapes and loft only the edges, leaving a empty shell in the centre.

Edit:
I tested this and it does not work, so i went back to the drawing board.

What I did was I made 4 sketches as seen below.

I then made an offset of each sketch as shown below

I lofted both sketches making two bodies.

I then subtracted the smaller one from the bigger one and got my final product.


I am still new to S3D and plan to purchase it one day.

3 Likes

My desired thinckness is 1mm. But the most nearest thickness i can achieve on my lofted body is 0.91mm. Can you help me achieve 1mm thickness? I will really appreciate that.

I am awaiting a response from the S3D Team regarding this Lofting problem.
There seem to be others having similar problems?
Hang in there and hopefully theTeam will kick in soon.

posts received from email can’t be edited. so i deleted all the post that contains your info. i am new here. i didn’t know that posts received from email contains personal info. i am sorry.

@Bradley
Firstly sincere thanks for your prompt and effective action.
I will amend my responses appropriately.
It was absolutely not your fault.
Please be aware that I am not a member of the S3D Team.

I have requested help from the Official Team and they usually respond as soon as their resources are not fully occupied. I understand your frustration, please hang in there.

if you read the Forum often you may have seen another Members Post regarding a very similar problem with Lofting followed by Shelling.

Hello @Gelphyn @Bradley

We are reviewing the problem - will keep you posted once we have a better understanding of the situation

@Bradley Shell works if you make the wall less thick (e.g 0.5 mm). 1mm thickness is simply not possible in this case (we use Siemens Parasolid as a geometric kernel) - you have to change your body to achieve 1mm wall thickness

how can i determine the biggest thickness, given a particular body.? which part of my lofted body refrain me from shelling 1mm thickness.

Did some testing, and it is the narrow part of the body (maybe changing the circle profile during loft would help).

We will change the shell tool’s behavior in the near future, and you will be able to control the wall thickness with arrows - this will help you settle on the maximum, achievable wall thickness. This will go out with 3.34 or 3.35

2 Likes

@Daniel_Shapr3D
Very interesting and it would be great to learn more about the limitations of Lofted Bodies, with regard to the criteria to observe if you need a Thicker Shell.
I have never encountered a situation where Shell failed to provide the required thickness in any of my Designs.
Is this current problem due to the complexity of the Loft?

Certainly looking forward to the Loft update :sunglasses:

thanks! i am looking forward to the new version.

@Bradley
Are you aware that S3D 3.34 has an update to Shell?

Firstly for the information to the Community, this is about this specific Design only.

Tap on the the Face you wish to remove > Tap on the Dimension Selection next to the Double Arrows > Type in 1 [mm] and you have the result you are looking for:

Dragging the Double Arrow and snatching a ScreenShot you could capture this image, but it is only a captured Image it reverts to 0.0mm:

However that is as far as it goes, Direct Dimension Input only works up to 1mm.

It would be good to understand the problem with this Design.
Certainly things are awry, compared to the Outer Surface the Inner has additional Lines and ‘artefacts’:

                OUTER                                 INNER

Attempts to use a Copy side by side with the Original, for comparison purposes, and then Shell one Body failed. Hitting the Green Check Box immediately changed back as if it had never received an input, i.e., nil action from the S3D Icon to indicate anything was happening.
The problem seems be connected to Splined Closed Sketches, given that all Closed Sketches created without using Splines have been successful?

Please tell us if you are able to get the result you wanted.

Finally! Because i’ve had many issues with shell not working where a certain thickness might have worked. Thanks! :wink:

1 Like