Aligning bodies exactly

I my model I have a number of bodies. I need to adjust the positions of these so that they are exactly touching each other. When I try to do this using Move and Rotate, the arrows to mode the body are often off the screen when I am sufficiently zoomed in to see accurately what I’m doing. Is there a way to get around this problem?
Is there a way to exactly align the points on two different 3D bodies?
Is there a way to merge two bodies into one?
Thank you - Rowan

Have you tried the Align tool?

Speaking of the alignment tool:
I have often had the situation where I wanted to align two surfaces, but with a distance between them. That is, without them touching each other directly. It would be great to pass the alignment tool a value of how much distance they should have after the operation is done.

You can easily combine it with the other transform tools, which makes this possible.

But how? :thinking:

Align object A to your desired surface on object B. Use the Move/Rotate tool to move object A away from B.

Okay, in my opinion this isn’t “a combination of transform tools”, this is just a serial usage. What I had in mind is doing so in one step.

If all I want to do is align the bottom (or the top or middle) of a set of objects then this should be easy. As it is, the align tool seems to be more about lining up objects about centres such as the example given, but in practice the objects fly off somewhere unexpected or stack on top of each other. Most confusing especially with more than 2 objects. Translate is often suggested but it’s hit or miss if the objects are exactly inline - zooming in shows this. I’ve mentioned before the alignment tool in TinkerCad - really easy and intuitive. I’ve made an example …

1 Like

so I had the same issue at first
I found that there is a difference between the Align tool in Sketch mode and whatever “normal mode” is called… so the process is:
without the shape selected, choose “Transform”
Then from the next menu choose Align
Then follow the tips which tell you to then select the object you want to move
Then Click “Next”
Then Select a face which is like selecting the local plane for the object or something
Then Select a face on the target object
Now as you say, at this point your object may jump to the centre point somewhere off screen, BUT, the tool is not closed yet, and you can still move the object within the set plane, and here you will be able to snap to the edges and faces of target object in the way you want

Its harder to describe than to do, once you get the hang of it

Thanks for the instructions. It’s basically what I have been doing and as you say the objects jump to align their centres which is not what I want. Yes, they can be moved back but when you have multiple objects this is not particularly feasible or in fact desirable.
But I have found a workaround using a construction plane!

  • Add a plane to where you want the objects to align.
  • Select object
  • Click Align
  • Select the face on the object you want to align then click on the construction plane.
    This even works for multiple objects which are aligned already on the same plane. If not then you’ll have to align each object. This works for faces of objects but I cannot see how it will work to align centers along a plane.

But I still suggest that a simple alignment tool is provided along the lines of the one I illustrated earlier in the screen video.

This is the use case for the Ansys SpaceClaim Pull “up to” feature.
This is a Pull Tool option where if you pull a face another face the pulled face becomes fully coincident with the pulled to face and removes any “invisible” incongruities that routinely make objects not merge. There is also a “no merge” option which is extremely important.
I was attempting to build a Saloon Table Bracket in Shapr, and this is a model that requires a lot of experimentation. But experimentation with solids rapidly builds in miss matched surfaces that defy alignment resolution so when you want to bond the various parts together the model becomes unwieldy.
I had to move the model to SpaceClaim to resolve a number of such issues, and finish the design there.
So that was a Shapr3D fail, and issues like that make it hard to start various types of designs in Shapr as I know that these issues will arise.
Any surface that is supposed to be one surface but has a line across it, it will not fillet correctly. That is the outcome.