Cannot log in to forums within app


I cannot log in to the forums within the app. Keeps saying incorrect log in.

I use an app (1 password) that stores and automatically inputs my passwords for me. Therefore, no user error in typing.

I log in here just fine, but not allowing me in the app.
I’m on the free version (want to test for game modeling before committing)

Is this a bug or because I’m free user?

Hi @tactfulgamer Welcome to the Forum.

Sounds like you are raring to go, and to hopefully avoid further delay you may wish to try the following:
It is assumed that you Signed Up for the Free version of S3D.
Is there a possibility that you have not Signed Up for the Forum?
If you are Signed Up for Both Accounts, are you sure you are using the correct Log In for the Forum?

Happy S3Ding.

Don’t know if this helps the devs.
Found the problem. It’s quite confusing so I have to give the sequence of things. After somebody reads this…

I would need to know if this will screw up my subscription once I start paying?

(1) When I first installed & launched S3D, I created a log in for the app.

(2) When I tried logging into the forums section via the app, using the same password I used to create the S3D app account - it wouldn’t let me. Kept saying wrong password.

(3) I assumed, this was because I had to create a separate forum account. So I did… I used the same email, but gave it a separate password. The forums sent me a verify email link, I confirm it. I was able to log into the forums just fine - - from my safari browser. (Not from within S3D)

(4) I then use the same log in credentials and tried logging into the forums from within the S3D app. I kept getting wrong password error - - again. (Naturally this brought confusion)

(5) In the midst of all this, I receive an email from S3D asking me to verify my email. (I immediately recognized this was to verify the S3D app account for I already verified the forums account) but this arrived late, I created the S3D account yesterday.

(6) Turns out this was the reason why… I couldn’t log into the forums from within the S3D with my initial account, that I created for the S3D app, because it wasn’t verified. Now I can log in fine from within the app. But it leaves me with potential issue question…

(7) I think the system, automatically merged two accounts into one? Here is why I am asking this…

• Both of my accounts have different passwords.

• The S3D discourse forum account password is different from the S3D app account password.

Yet… strangely enough, I am now able to log into my forum account, from within S3D… using the S3D account password - not the forum account password.

How is this possible when both accounts have different passwords? (They only share the same email) The system should be prompting me with a incorrect password alert because I didn’t use the forum account password to log in, I used the S3D app password to log in. See my dilemma?

Will this screw with my subscription account when I start paying?


You obviously had put some effort into Logging In, suggesting that you were very keen to get everything sorted. My input was an attempt at a possible quick fix.
Glad to hear that suggestions regarding using the App Account credentials for the Forum, and vice versa, are duly covered. Your explanation should help.
One of the S3D Team will chip in to get this sorted.

Hi, thanks for the very detailed feedback.

The app and the forum are different platforms and do not share login credentials.
You will still need to create an account to log into the forum( you can decide to use the same details as that of your Shapr3d account)

@Victor_Shapr3D Though you are saying it differently - - you are basically telling me… this will not screw up my S3D app credentials that will be connected to paying for my subscription. Got it. Thanks.

@Gelphyn you were helpful as well, I appreciate you. Thank you

1 Like