Editing Imported Design in Solidworks

Hi! I’m a new user.

I tried exporting my design into Solidworks to view it there and when I do, I am not able to view every part/ sketch nor edit anything that was exported. I tried using the x_t and the stl formats, but had no luck. I also had the same problem when importing a solidworks design into shapr where I couldn’t edit the design; it seems as if it is unioned together.

Any help or advice is greatly appreciated!


When transferring your files between CAD software, please avoid STL and other mesh formats if possible. Mesh files are different from the CAD models you can create in Shapr3D or Solidworks. In your case, X_T seems to be a good solution.

Can you please share what prevented you from editing the imported X_T in Solidworks? Please feel free to share the Shapr3D design, the exported X_T file, and some screen recordings, it could help a lot for us. If you do not wish to share them with the public, just open a support ticket using the link below and we’ll check what could be the problem.