Faces remain after extruding - no way to delete them?


Two related issues -

  1. when I use extrude sometimes I am left with a face I don’t want. See the attached screenshot. This happens every time when in sketch mode I ensure the line I am drawing is right on the edge of the shape I am extruding through and in the attached screenshot it happened when I made the 2d shape much bigger

  2. I cannot find any way to delete or remove the leftover 2d plane without removing the entire shape.

I’m sure the answer is absurdly simple but I am not finding it after a lot of googling and trial and error.

Image from above post. Apologies for the low quality

that seems to be the inital sketch.
Open the Item-Explorer and try to hide it by c

licking on the eye!
Cheers Matt

Thanks for responding Matt -

it’s a very very thin slice not the original shape (talking about the vertical grey face not the blue horizontal one)

I’m having a consistent struggle with getting results like that when I think I have drawn a shape in sketch mode that abuts the edge of the thing I want to extrude through, then I extrude and find I am off by a microscopic fraction and have to go clean up.

I’m playing with the snap settings right now to try and avoid this, after messing around all morning I just realised that moving or copy pasting objects in sketch mode does not snap them to the grid or other shapes so I’m looking for a way around that.