Offset not working with spline tool

Hi there! I am having an issue with the offset to not working when my sketch includes the spline tool. I’m pretty sure the design is closed Because I can use other tools such as extrude and shell. Is anyone else having this problem or am I not doing something right? Thanks in advance!

Hi @4monkeys Welcome to the Forum :sunglasses:
Thanks for explaining what you have tried, it would seem that Sketch > Offset should be working on your Closed Sketch.

This shows Sketch > Offset > Loop has worked with a Spline as part of a Closed Sketch:

  1. Can it be assumed that your Closed Sketch is filled with Light Blue as in the above ScreenShot?
  2. What Offset Type(s) have you tried [Loop or Single or Both]?
  3. Create a New Design and replicate your Closed Sketch then try Offset again.
  4. If Offset is still not working for you use one choice from Sketch > Circle/Rectangle/Polygon/Ellipse to create a Closed Sketch and try Offset with that.

Shout if you still need help.
Happy S3Ding :sunglasses: