Subtraction not working

I have subtracted all of the other hexagons, but these 4 are stuck, and I don’t know what to do.

Hi @Jake3123 Welcome to the Forum.

Have you tried Selecting the Top Face of one Hexagon and then Push Downward on the Double Ended Arrow until the Hexagon disappears? Just the opposite to extruding.

Alternatively Select the Hexagon and hit Delete.

It appears that you Sketched all the Hexagons on a Surface?
If that was the situation all you need to Select as many as you can and Push the Double Ended Arrow Downward.

Shout if you still need help.

Happy S3Ding.

Well I ended up putting an opaque hexagon photo over then imported file, so the sketch is 1mm in the air. I make the hexagons and then extruded them through the imported base, then tried to subtract the hexagon. I tried both of these methods and neither worked. When I tried to unify the extruded hexagon and the base, it gives me a Boolean error

Is it possible for you to Import another copy of the Base?

If you can it could be used in conjunction with the Sketch Plane containing all the Hexagons to quickly recreate the result you need.
The Sketch Plane can be found inside Items:

You will see an Eye Icon to the right of all Item’s Entities, Tapping on an Eye will either Hide or Show that particular Item.

If the Base you need is available please Import it into a NEW Design, leave your existing Design untouched, and Post a ScreenShot of the new Base.
Double Tap with a Finger on the Top Face of the Base and position it to show the whole Face.
We can pick it up from there when you are ready :sunglasses::+1:

I am going to restart because I want to rotate and add a few things. If I still encounter the same problem I will reply again. Thanks for your help.

You are very welcome.
Remember you can always try pushing one hole through, your friend is the Undo Button.
Enjoy experimenting.