There are invalid bodies in the model that cannot be exported

Hello, I’m receiving this error when I try to export my model to STL or SMF. I tried deleting the fillets which did not help. I tried deleting the mesh bodies I had imported into the model with the same result. Is there way to tell what shapr is finding invalid, or at least a way to tell prior to running the export and finding out then which is pretty annoying. To be clear it will not export anything valid at all, Cura says its corrupt.

I will add I also recreated the sketch to receive the same error. Its not really complex, its a triangle stand for a plaque. I was down to just a modified triangle at the point of the last error.

The limitation of the free product for 2 files is really rough for someone trying to learn CAD and your software, adding to frustration. I’m just a hobbyist trying to learn something new.

Hi @Duder! Could you please upload some screenshots of the model you cannot export?

I just re-did it entirely in a new project and it worked. The reason was because I was designing multiple things in a single project because like I said I’m trying to learn stuff, and see what I can do but limited to 2. I would think the low rez export alone would be a deterrent from remaining in free mode as it turns circles into Octogons when printing. I do appreciate your reply anyway.

If you have a model with many bodies and you want to find out which bodies are invalid. Try selecting all with the selection body tool. The invalid bodies will not be selected in this option. This is at least how to detect which bodies are invalid in a complex assembly


That’s a good tip @sander , :+1: