Union when extruding circle inside of a hallow circle not working

See video for reproduction

Issue: when trying to extrude a circle inside of another hallow circle, it doesn’t allow to union


  1. Create a sketch with an outer circle and an inner circle
  2. Extrude just the outer circle to 10
  3. Extrude the inner circle to 5
  4. Set the extrusion type to union
  5. Finish

Observe: a new body is created

6. Go to history
7. Find extrusion
8. Change type to union

Observe: it does not union

9. choose Tools > Union
10. Choose both bodies

Observe: bodies are finally unioned

The auto union only applies to bodies that overlap, it won’t union bodies that only touch each other. We could change this behavior, but it’s not trivial to decide which behavior is more intuitive/useful.

Hm… I would definitely want the ability to union them in this situation. Or… at the very least, some sort of warning message that says it’s not possible. Although I am able to union them normally so it definitely is possible

I would vote to allow for auto union in a case like this where they’re tangential. I wouldn’t mind if new body was still the default but I’d like it so when I change the combine type it actually works


It is possible, in the feature tree you can manually select the other body to be used in the union, we just don’t do it automatically.

It’s really not obvious if this is the right behavior or not. Eg consider this case.

Or this case.

I can imagine situations when you want to union them, and situations when you don’t. How would you decide? I’d love to lear how you think about this, it’s a tricky user experience question.

I suppose my thinking is a bit skewed coming from Fusion where it will only default to “new body” if the extrusion isn’t touching any other bodies. So, that’s just what I"m used to. And, based on that, I would expect example 1 to union by default and example to to not (since I think it would be impossible to union those)

But… if there were an easy enough flow for telling it to union (if the default is new body) then I wouldn’t mind so much. But the fact that I tap on the shape icon (combine?) and choose union, and nothing happens is what frustrates me. Don’t let me choose the option if nothing will happen as a result. And, after choosing union, I see no way to choose the target bodies.

In fusion, the combine feature (and a lot of other tools) have sections where you choose “target bodies” and “tool bodies” where (in the case of subtraction) the tool bodies would be used to cut the target bodies. not as important in a union but having that interface where you can choose the extra bodies might be useful to have

And separately: it also doesn’t work when changing the combine type in the history viewer as it just completely dismisses the edit panel


@alexkrush it’s indeed weird and misleading that selecting the union option does not offer you an interface to pick the targets, thanks for your feedback, we will improve this. In the meantime, if you set the type to union via either the badge on canvas or in the history step editor, and then click “select” next to “#CobineTargets”, then you will get a picker to choose the target bodies. It should happen automatically though.


At the very least, the union option should be grayed out in this situation.