Weird grid orientation

Hi,

It’s hard for me to put my issue in words. As you can see on the screenshot below, my grid is somehow in a different Rotation/angle than my objects. Is it possible to reset my grid so that it is in line with the x and y axis again?

Thanks

You can use Move Tool to move your gear to x and y axis. Basically bring it to the centre, also your can change the angle with it.

Yes, but the problem is that the grid is in a different angle than the x and y axis. I can never draw rectangles and stuff anymore because they are not aligned along the x and y axis (see the rectangle in the upper gear). And I guess the reason for that is the grid.

Can you please send your workspace? Thanks

Here I attempted to create your weird grid orientation. I placed a construction plane on the surface of a body. Then I rotated the plane in two axis. When I double tap on the cube or the body, the grid orientation is correct. When I double tap on the skewed construction plane, the grid is skewed as well. Hope this helps in some capacity.
-Mike

I found out that the cause is one of my sketch planes.
I have recorded a video for you guys to see it in action.When I delete the sketch plane, it will align properly again (rotating the sketch plane does NOT change the weird alignment at all. It stays off at the same weird degree)

Unfortunately as a new user I am not allowed to upload attachment, so here is my workspace file and a video on YouTube

I have added a video and link to the workspace. Unfortunately I am not allowed to add attachments

I solved the problem ,please check the attached the file.
shapr3d_export_2021-05-27_14h08m.shapr (691.5 KB)

Now you can draw your sketches on it.


1 Like

Hello Rohan,
thank you for your efforts. I understand that you have removed the sketch plane to fix the alignment like I had mentioned in my previous comment?

I was wondering why this has happened in the first place and how I can fix it without deleting the sketch planes which have been causing it. In this case it’s no problem because the respective plane is simple, but in more complex cases, recreating them from scratch will waste a lot of time.

Try moving the sketch upward, you don’t need to delete it.

1 Like

Hello, please do not forget that under the Add menu there is an option to define Construction Planes by several options. In this case Through Edge at Angle could be really helpful. So there is no need to rotate the bodies in the workspace :slight_smile:

2 Likes