Why can't I edit an STL file after importing it?

Hello everyone, I have a small question
Why can’t I edit an STL file after importing it?
Is there a way to convert it into an editable file?

STL is a mesh and not a parasoilid file type. Shapr cannot edit mesh file types like stl, obj, etc.

You can use Fusion 360 to convert it to a STEP file, which is editable in Shapr.

Out of curiosity I tried a simple STL object. Fusion to STEP.
Fails in Shapr3D and in any of my other CADs.

2024-06-21 14.39.22

Screen Shot 2024-06-21 at 14.21.15

Looks OK, but the geometry is missing

/* Generated by software containing ST-Developer

/* description / (‘’),
implementation_level */ ‘2;1’);

/* name / ‘Pencap V2 conv.step’,
time_stamp / ‘2024-06-21T14:17:42+02:00’,
author / (‘’),
organization / (‘’),
preprocessor_version / ‘ST-DEVELOPER v20’,
originating_system */ ‘Autodesk Translation Framework v13.14.0.145’,

/* authorisation */ ‘’);

FILE_SCHEMA ((‘AUTOMOTIVE_DESIGN { 1 0 10303 214 3 1 1 }’));


OBJ worked from Fusion (good result) but unfortunately S3D does not import this format.

Did you do a repair on the mesh within Fusion before attempting to convert it. Can you post the STL?

I tried some repair variants, even an ugly rebuild, no luck. Though, it would be a nice option to have if ever needed.

You did noticed that STL → OBJ is OK?


Pencap V2.stl.zip (326.0 KB)

(It stops my ‘old’ Apple pen from rolling off the table. It has room for Lightning to Lighting adapter if replacing original cap and a spare one protect the tip-end in the backpack. Print ∼103% in som slightly (shore 95) elastic material).

Just for fun, looks good;
S3D → STL → (no repair) OBJ → STEP → S3D

Pencap V2 roundtrip.shapr (7.3 MB)

I didn’t have any issues. I inserted the STL into a Fusion design, converted it in the MESH menu, exported directly as a STEP file, and loaded it into Shapr3D. I’m running Shaper on an iPad Pro M2.

Pencap.step (16.9 MB)
Pencap.shapr (5.9 MB)

Strange… so Fusion does different delivery for us. I will look in to this later. (I run Fusion on a M2)

In my experience trying to turn an STL into an editable file never goes down well. I think of them as read-only files at this point.

As do I.

I’ve rarely had an issue with converting them in Fusion, especially since Autodesk rolled the mesh repair tools from Meshmixer into the app. I typically do some clean-up on them though, mainly simplifying flat surfaces, before I export to STEP. I didn’t do any clean-up in my test above.

Hmm not tried Fusion, mainly done it with FreeCAD and the resulting mesh is usually way too complex, the simplifying tools don’t seem to make must difference either. Maybe Fusion is better? Does the free version support it?

Yes. There’s one option (Prismatic) that requires the paid version; it can convert segmented mesh “curves” into smooth curves.

Well just my luck it was curves I was trying to smooth haha. I remember at one point I even tried to select 100s of individual segments in Shapr to see if I could adjust a wall thickness :sob:

Hey, I just signed up for a free trial so I can use the Prismatic feature but it seems to be too aggressive and is leaving holes in the model. Any ideas?

EDIT: Okay I realised you can use the combine face groups on troubled areas to help the algorithm

No help to you now but its rumoured the full release of ChatGPT 4O will convert .STL to .STEP. I’ve already had success using GPT4o to convert some simple shapes from .STL to .IGES with a degree of prompt engineering (example below). So its coming…

“Create, debug and run python code without using external software or freecad, to decode the attached .STL file and translated it into an .IGES file”

( I’ve also had some dimensioned basic shapes and even simple models such as a flower generated purely by text, outputting in .STL directly by ChatGPT 4o. In the future its not beyond the realms of possibility of bypassing CAD altogether and designing simply by talking through the design! I’m playing with a 3D LLM that’s starting that journey now. Exciting times… )