0.32 - Standalone installer for Shapr3D on Windows

Hi everyone,

Every so often, buying and updating apps from the Microsoft Store can be far from quick and easy. However much time you spend navigating the murky waters of the Store, we want you to spend it knocking yourself out with Shapr3D - Early Access.

Download Shapr3D’s standalone installer — directly from our website today. Use this link: https://download.shapr3d.com/windows/Shapr3D.Package.appinstaller.

If you already have the website’s home page open, you can follow these steps:

  1. Select Download Shapr3D on the home page.
  2. Under Windows, select Get it from Microsoft.

    A new tab will open, directing you to the Microsoft Store.
  3. Close the new tab.
  4. Click Download the installer to install the app manually.
3 Likes

Honestly, the installer should be the default and the store secondary. I don’t know many people who like using the Microsoft store…

1 Like

Yeah, we thought a lot about that, too. The Store indeed does not get much love, but when it works, it works well, and it works for almost everyone, even if it’s not the first choice. It solves upgrades seamlessly and your apps are available with a few clicks when you start using a new machine. We might change the default later on, but we thought we’d start with this.

Do you have any particular issues with the Store or it’s simply that it wouldn’t be your first choice when looking for an installer?

1 Like

Mmm well for me I just prefer to click download and getting the installer. I don’t really like having to get forwarded to a new site and going through downloading from there.

Not the end of the world though, can be changed later or kept the same.

1 Like

Why are you calling this standalone, if it’s not executable and still requires to have Microsoft store in system?
I don’t have Microsoft store and don’t want to install. Ah why are you using windows store to distribute programs? Even Microsoft start to sell games in steam because no one using it.

Hi – and welcome to the forums!

If you click on the “Download the installer” link as shown above, you can download an ".appinstaller’ file. App Installer is a standard Microsoft technology to distribute apps that offers many features, most importantly seamless upgrades, which is paramount for a rapidly developing app with bi-weekly releases like Shapr3D. It’s independent from the Microsoft Store – you don’t need a Store account for it to work, nor install the Store itself. We tested it in a number of ways (including things like forcibly blocking Store access on the network) to make sure that is the case. The only potential issue can be is that if you have App Installer manually uninstalled (it gets installed for all but the most stripped-down/restricted versions of Windows), it’s tricky to install it again without the Store. Let me know if that’s the case for you or you can’t get it work so that we can figure out and fix the problem.

We don’t want to push anyone to use the Store if they don’t want to use it – but based on what we’ve seen so far, it works better than a standalone executable for most people. It takes care of things like install permissions, background upgrades that honor your network settings, network access issues, faster peer-to-peer distribution of files, problems with anti-virus and malware scanners and many more. Many centralized endpoint management systems can also pull software from it seamlessly. But we understand that it’s not a good choice for many, and that’s why we have the standalone package.

Hi .appinstaller don’t recognized by my system.
I suppose it requires to have

to install it requires to have Windows Store in system. Without Windows Store not a single app can be installed from it.
So you cut users what do not have Windows Store, who delete it or who using LTSC windows for work.

The LTSC build of Windows is indeed the only version that doesn’t have App Installer pre-installed by default and we indeed don’t support it by default at the moment. Could you help me understand the reason you are using the LTSC build? It’s usually targeted towards more specialized environments, and has a small market share, so we decided that it would be acceptable to not support it with the initial release, but there might be factors we don’t fully understand at the moment.

I’m afraid the best workaround we have at the moment is the following:

It’s not the best solution though as it does not install the dependencies (mostly the Visual C++ redistributable) and the app won’t upgrade itself automatically.

The reason is simple, i do not need all features what was removed in LTSC like pre installed, Microsoft store, xbox stuff, cortana, edge browser, skype etc. Just need stable windows for a work. And i think many people thinks like me, at least who work in CG.

  • look into the .appinstaller file with Notepad

as i said it won’t install without microsoft store. I already downloaded it even unzip and tried to run manually, but do not worry, LTSC also is not supported by build number to run shapr3d, so i have to wait 21h2 for LTSC what should released soon, i think

1 Like

Thanks for the info. It makes sense and we’ll definitely check if we can support the new LTSC release without any workarounds. I am honestly not sure why Microsoft decided to to remove App Installer from the previous LTSC build – it’s just an install mechanism that works independently from the Store. It could be connected to the fact that LTSC systems are usually designed to remain static, so things upgrading frequently is precisely against their design, whereas the main added value of App Installer to keep things up-to-date.

For me too - none of the provided ‘direct’ installer works. Keep on getting

App installation failed with error message: Deployment Add operation with target volume C: on Package Shapr3D.Shapr3D_5.0.32049.0_neutral_~_dvv5p1vgwv6mp from: (Shapr3D.Package_5.0.32049.0_x64_ARM64.msixbundle) failed with error 0x8000FFFF. See Troubleshooting packaging, deployment, and query of Windows apps - Win32 apps | Microsoft Docs for help diagnosing app deployment issues. (0x8000ffff)

Even after unpacking Shapr3D.Package_5.0.32049.0_x64.msix from the package I’m getting

App installation failed with error message: Deployment Add operation with target volume C: on Package Shapr3D.Shapr3D_5.0.32049.0_x64__dvv5p1vgwv6mp from: (Shapr3D.Package_5.0.32049.0_x64.msix) failed with error 0x8000FFFF. See Troubleshooting packaging, deployment, and query of Windows apps - Win32 apps | Microsoft Docs for help diagnosing app deployment issues. (0x8000ffff)

I’m a software architect / developer and since more than 20 years in business. To me it comes to no surprise that no one likes the MS Store - it was a pity (being polite here) from the beginning. With all that ‘auto-update-nonsense’ that make things unnecessarily complex, complicated and error-prone - I would never put my customers through that kind of trouble and still would rater chose the ‘old fashion’ (and still seamlessly working) msi-Installer. Let them decide whether and when to update.

I have being waiting desperately for the Windows version of Shapr3D (I’m on a Business plan) – but this is far from being fun.

Hey – thanks for the feedback. And I’m sorry for causing so much frustration: Microsoft Store and AppInstaller/MSIX seems to be working just fine for the majority of users, but for a sizable unlucky minority, it just fails spectacularly. We are investigating all options to make the experience smoother, but our hands are somewhat tied due to Shapr3D being an UWP app (which it had to be due to a few unrelated technical reasons).

In your case, “0x8000ffff” is just a generic “Catastrophic failure” error code from AppInstaller, which is, obviously, not very helpful. Since you have a background in software development, could I ask you for a little debugging? What I’d like to try is to take AppInstaller out of the equation to see if that’s causing the problems or the issue is somewhere else. For that, could you try installing the MSIX bundle via PowerShell, using the Add-AppXPackage cmdlet?

Hi there,

yes

Add-AppxPackage D:\Downloads\Shapr3D.Package_5.0.32049.0_x64_ARM64.msixbundle

worked like a charm! Thanks :ok_hand:

One more word on tutorial … it would be nice if you let the user choose whether or not to go through. In order to install via PS I had to first uninstall my old version. After installing I had to go through the entire tutorial - and this after using Shapr3D almost daily for roughly a year now :face_with_raised_eyebrow:

Hi Peter,

With the LTSC 2019 I can’t install it this way, my os version is 10.0.17763.2746.
Can you lower the TargetDeviceFamily MinVersion?
Looking at the AppxBundleManifest.xml it shows me:

<b4:TargetDeviceFamily Name="Windows.Universal" MinVersion="10.0.18362.0" MaxVersionTested="10.0.18362.0"/>

Thanks,
Lars

I’ve tried to repack after modifying the file but looks like it gets corrupted as an install package then.

1 Like