Error on App start - Windows

Hello All,
There is a special situation in our company - the windows store is hard deactivated and removed from our Installation Image…
So i worked the last 2 days to get going and now i am at the point, that i can install the shapr3D for Windows BUT if i open the app - it just appears for 2 seconds (not loading a start screen just a white window) and closes itself.
In Eventviewer i have the following Error
"
Name der fehlerhaften Anwendung: Shapr3D.exe, Version: 1.0.0.0, Zeitstempel: 0x61fbb513
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.19041.1466, Zeitstempel: 0xe01c7650
Ausnahmecode: 0xc000027b
Fehleroffset: 0x000000000010b362
ID des fehlerhaften Prozesses: 0x1554
Startzeit der fehlerhaften Anwendung: 0x01d81dcd0d5d06d8
Pfad der fehlerhaften Anwendung: C:\Program Files\WindowsApps\Shapr3D.Shapr3D_5.52.36990.0_x64__dvv5p1vgwv6mp\Shapr3D.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\KERNELBASE.dll
Berichtskennung: e632e9b4-8178-4b3c-ad59-1f1810d44c46
Vollständiger Name des fehlerhaften Pakets: Shapr3D.Shapr3D_5.52.36990.0_x64__dvv5p1vgwv6mp
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: App
"
I think it correlates that we have no windows store - as far as i worked on this problem i can not get the windows store working…

Has somebody any idea or any help for me?
Thanks and Best Regards
Manuel Kollmann

Hi!

How did you install the app in the end? Have you used some of the alternative options from the download page, “Install from Shapr3D.com” or the MSIX Package?

Also, what’s the exact version number of your Windows installation? It should be available in the “Settings” app in the “About” section.

Best,
Peter

Hi Peter,
first at all - thanks for the fast response !
My Windows Version is: W10 Enterprise 20H2, Build: 19042.1466

So what i tried till yesterday:

  • i opened the Appinstaller with a Notepad and tried to download the single Packages - this worked and i have every package or a newer version on my Notebook, so i was not able to install them new.

The reason why i installed the .msixbundle Package is:

  • the Windows Store is hard deactivated and deleted in our deployment Image. I tried to reinstalled it but i was not able to do it. As a result of this, i was also not able to download the appinstaller to install it cause i cannot open the appinstaller - its not recognized from windows and i cannot open it with a double click.
  • So i was able to open the .msixbundle with the Powershell and installed it as Administrator. The App is on my Notebook but if i open it i only see a windows for 2 seconds and then it disappears…
    The rest is already in the Ticket.

About the windows version - i have another Notebook with 20H2 and there it works. But its not with the same deployment installed - and the Windows Store works on the other notebook.
So something may depend on the windows store whats not on my notebook.

Best Regards
Manuel

Thanks for the info – and kudos for going through all those steps. Unfortunately, Microsoft does not offer a good built-in way to install UWP apps along with all dependencies for systems where App Installer is disabled/removed. We are looking at all kinds of alternative solutions at the moment.

I believe my colleagues are already assisting you over a support ticket, which might be a better forum in this case as there are folks there who can focus solely on this. If we come up with a solution that’s applicable for the wider audience, we’ll share it here as well.

Dear Peter - thanks for the reply,
yes - i am in E-Mail contact with some colleagues of you.
At this moment, i can only wait till i get an answer.
Best Regards