Can’t Align lines or sketches

I’ve put up with an issue for ages but it’s finally causing me enough grief to try to sort out.

It’s almost like a reverse snap to grid. But it’s a “won’t snap to where I want it” , it snaps somewhere past where I want it.

what it is is that when I try to align lines or sketches to exactly overlap, the one I am moving will move closer and closer to the position I want but then it snaps past the line or point.
The true Snap to grid is turned off, and the position it snaps to is usually or often not on a grid line anyway.
In order to get it to get really close I have to enlarge the screen image of the sketches to a more honed in view. Sometimes it will then move smoothly to where I want or sometimes I have to move it as close as I can and then re-magnify the image and repeat getting closer each time.

I’ve persisted doing this but I sometimes run into the issue that when I magnify it enough either the dragging arrows or the lines I am trying to align then go off screen and I can’t perform the task.

What am I missing here? There must be some way I can just drag any line to any place I want without this frequent “anti-snap to grid” event.

Hello John - can you give us an example (video if possible) - it would be a great help, and maybe we can fix the issue

Sure but Can you advise on how to generate the video?

How to create the video: on iPad (I assume), open Control Center. Touch red Screen Record button on bottom right. Record. Touch same button to stop recording.

I am having the exact same issue. I usually will have to zoom way in and try again to move the solid object, extruded face, or sketch line by smaller increments to get it to line up. Like you experienced, most of the time it seems like whatever i am moving wants to snap past the target. It would be great if we could locate a line, face, plane, etc. after we were in the “transform” mode and then the object would snap to the selected line. That would be a huge time saver. I spend most of my time trying to re-align things perfectly.

Ok thanks. I’ll give it a try.

Ok have done a short video ( sorry but your instructions didn’t help. Your instructions only let me use the camera to take a video. Couldn’t take a “screen shot “ type video of the page of the same iPad.
I had to take a video with my phone of the screen of the iPad so quality isn’t good but you’ll get my meaning.

Som in this case I just drew two rectangles and tried to move one to align the edges but this happens with simple single lines, other shapes etc.

Sorry but that last post was an error. Couldn’t delete it and it somehow sent itself.

Ok part of it is relevant.
I made a video on my iPhone and airdropped it to my iPad. But have no idea how to attach it to a post on this forum. There are no image or video attach buttons. Can you advise?
Thanks.

FYI I found out how to take screen videos.
Still no idea how to attach them to a spot though.

Hi John, please try again and you should be able to upload the video now.

It’s just a short example. Happens with Any sketch shape from single lines being moved either to align with other lines or with sketches of rectangles, polygons etc.

Happens mostly when the size of the moving object is largish ( maybe over about 20 or 30 mm in size)

Can get it back to full control of movement if I magnify the view enough so that the visible squares are small, like 1 or 0.5 mm Or smaller.
But sometimes have to do the magnification several times. And as I said some of the time the magnification may then make it so either the dot / moving arrows are in shot but the line I am moving is out of screen. Or the line is in shot but the arrows are then out of screen.

Hi John, thanks for sending the video.
Let me share this with our development team so that I correctly inform you even though I have some suspicions on why that is happening.
I will get back to you as soon as I get feedback from them.

Hi John, to snap the edges move the arrow gizmo from the center to the edge of the sketch and then move the shape to try snapping the edges as shown in the video below:

Hi
Trying a simple move and align. Want to loft to arcs. Any hints? I’m trying to upload a video, but it’s saying I’m a new user and cannot do it.

Hi, you should be able to upload the video now :slight_smile:

Uploading: IMG_20200803_150032_737.MP4…

I’m trying to do this. I’m trying to align my arcs but can’t…

thanks for the response.
it helps a little but not much.
the two squares I used for the video are just quick and easy example. the problem exists with pretty much every object, solid, sketch, or combination of these.

the ability to drag the dot/ arrow heads doesn’t work for many objects or sketches. it stays locked in the centre and the whole object moves.

when it does work it helps in that i can then drag the dot/arrows into view near the edge I am trying to place so it helps. sometimes the edge becomes free and can be placed anywhere but often it still does the “jump past the point I want to place it. But if I keep magnifying it then I can eventually get it to sit most of the time where I want it.

But I have also realised that a lot of these issues could be solved if there was a way to auto align the edges or surfaces of the objects. Am I missing something or is there no way to just click on two or more objects and then align them?

My most needed alignment situation is that i have to design parts in-situ in the final object and then move them so that one surface on every piece is lying on a plane ( doesn’t have to be a formal xyz just all aligned ) so they can exported to a 3d printer slicer and print on the build plate. Manually aligning 20 small parts is a real pain.

Hi John, thanks for the extra information.

We started the planning process to implement 3d snapping and at the moment there is no ETA for when this will be deployed, trust me, we are going as fast as we can.

With 3d snapping, this will work perfectly especially with solid body faces.