Can’t Lock Distance At Current Size

I have two hexagons that are 1” apart and I just want to lock that distance, but seem to be having trouble doing this even though I did the same thing else where. I sent the file to you guys already after posting this message.

Hi Jeffrey, thanks for the workspace over. I see that you locked your angles and to lock the distance between the sketches:
Zoom into the workspace a bit more
Tap on the corner points of the sketch and then tap on the lock icon

I showed this in the attached video.

Okay, I know how to lock points, but why are you having me do this? Locking the points doesn’t make the error message go away.

I guess I do not completely understand your question, I apologize. What do you do that brings about the error message?
On your initial request message, you only mention that you are not able to lock the sketch at it’s current size. This can be achieved by simply locking the points.

Hi Jeffrey, thanks for your patience. My colleague helped to further look into the issue and we found a bug which we will be looking into fixing ASAP.

In the interim here’s a workaround you can try out as shown below:


I hope this is helpful.

1 Like

I apologize for not being clearer in my first post. I included a video this time to show you what I did that caused the error. The existing difference between the hexagons is already 1” and I just click the dimension number and clicked the green button without making any change to the size. I notice that when I do this it automatically locks the distance between them to be 1”. I did this without issue at the beginning of the file till I got to the point that I did and then issues started occurring. The reason I prefer doing it this way is cause I can move the hexagon afterwards without stuff warping. If I lock down the points I can’t move the object without unlocking them again, which is annoying since there are so many hexagons.

By the way, Thanks for your second video. I never thought to create them with a large hexagon as a guide. Very smart! Thanks for that. Not sure, if it’s cause I have a computer engineering degree or software development background, but I’m really good at find software bugs for some strange reason. I knew it was a bug when it didn’t lock at a size that it currently is at cause that just doesn’t make sense.

Hi Jeffrey, we could reproduce the issue here and we already created a ticket for it. Our deveolpment team will be working on a fix for the it. Thanks again for reporting this.

Hi Jeffrey, our development team fixed the issue. The fix comes in the next app update version planned to be released before the weekend. Thanks for your patience :slight_smile:

1 Like

Ok, awesome! After I get the update I’ll let you know the effect on my end. Thanks for such a quick bug fix and software update!


Okay great! we will be looking forward to your update.

I update my Shapr3D just now and tested the file I had the issue with, but no change. It still doesn’t lock a dimension at the size it currently is at. The video below shows the space being 1” apart between the hexagons and I tap the dimension, but make no size change and hit the green check button which should lock the size at 1”. It does not and gives the error at the top of the screen.

Hi Jeffrey, thanks for the feedback. It does work great for me. Please try exporting the file with the new app update version in shapr format and then reimport the file into the app let’s see if the issue persists.

Kindly give this a try and I will be looking forward to hearing from you.

It works now after doing that, but just so you know… I immediately tried it after importing and it didn’t work, but then I hard power down/reset my iPad Pro and then it worked. Make sense since some stuff is still probably running in memory even though I swiped the app up. A follow up question… when I export it as Shapr3D format and reimport… Is there any data loss in the files?

It’s great to know that it works now.
No, there is no data loss when you export and reimport files in shapr format.
For a file created in a previous app version with certain geometry issues due to a bug, exporting the file from an update app version with a fix for the bug could help fix the issue with the file.

1 Like

Seems like it fixed it throughout the app. Thanks again for fixing this so quickly and releasing a new update app. You guys are awesome!

1 Like

You’re very welcome. We are always more than glad to assist.

Hi Victor!

Is it posible you could help me with?

Im totally new in Sharp 3d. Im just trying to draw a thread in a simple cilinder but I cant draw it in the curved surface. I saw a 2016 video in these forums that looks so easy but I simply can draw the line.

Thanks a lot!

Omar Núñez E.

Hi Omar, do you have an image you can attach to help me better understand how you will like to have the thread placed in the cylinder?

Hi Victor, Thanks a lot for your fast response. Here a picture of a line drawn on a cilinder surface and also the video where it was drawn. I don’t know how he does that.

Thanks again

The video :


Thanks for your response Omar. That’s an old app version and some features work differently now.
Here’s a quick video on how you can create a threaded cylinder on the updated app version:


Also there is a video on YouTube created by@Pongsakorn showing a different method:

I hope these are helpful and let me know if you have any further questions.