Dims no longer stay placed

I started a new sketch last night and noticed that there are certain instances where the dims always snap back to a specific location, even after I have moved them out of the way. Is this a feature a bug? Ideally the dims should stay where we place them, because I know that I get them out of the way of the places I intend to sketch.

A very handy feature would be make it possible to turn them all off except for the active selection, just like the constraints.


Currently only locked dimensions stay in their place, unlocked ones move back to their default position, as you experienced.

That is very inconvenient. Certain dims don’t need to be locked and hamper iteration of the design if they are, yet when they get changed they snap back into a space where they’re blocking information. It’s a constant see-saw battle of clicking and moving and then doing it again as the design matures.

1 Like

Could you please provide an example of when dimension annotations are in the way? We’d like to understand more about your specific issue before suggesting anything. It might be that you found an undetected bug that we’re not aware of.

Please see the images below. This happens every time no matter where I put the dim or the value I change it to.

1 Like

Here’s the file for your viewing pleasure :grinning:

Dim Issue.shapr (115.0 KB)

Thanks a lot for clarifying, this is indeed a bug and should work in a different way: if you reposition a locked dimension, A) it should not change position when the value is updated, B) even if you exit sketching and come back later, that position should remain persistent. As a sidenote: we are considering to provide an option to hide locked annotations similarly to constraints, but regardless of that this is a bug that we will fix.

Woo-hoo! I break stuff…LOL.

The turn off dims option would be a welcome addition so this stops happening :grinning: or even better have them work like the constraints and give us the option to only see them based on selection.

1 Like