Double-tapping issue with Apple Pencil

Hey all,

I’ve been having an issue that has made the app unusable for me for the past month or so. When I try to double-tap a body to select it, most of the time it doesn’t work. For instance, if I double tap on a face of a cube the face will be selected and de-selected with each tap, no matter how quickly or slowly I double-tap. I’ve tried researching it to see if the command to select a body has changed, but it doesn’t seem like it. (Sometimes a series of between three and a dozen quick taps will land me with a properly selected piece.)

This wasn’t an issue for me before about a month ago. My version is updated and all my other apps seem to be operating fine with my Apple Pencil.I was considering upgrading to the full version, but not if this continues to interrupt my workflow so significantly.

Has this happened to anyone else? Is there another command that does the same thing as double-tapping?

Thanks for any help you can offer.


The current editions are all inexplicable and bring a bunch of bad experiences.


Same. I actually took some stats over a work session - on average it took me 4 attempts to be able to select a body. Bear in mind, that’s the average - usually it was 2-3, about 1 time in 6 it worked on the first try, and there were a few times it took me 10+ tries (if it took over 10, I’d give up and select the item from the menu).

Thank you for making this thread @Habilis. Please give this some love, Shapr!


Thank you for reporting this, we are looking into it.

1 Like

Did a little investigating, and I think I have some potentially helpful info. It tends to work almost flawlessly when I first open the app, but becomes somewhat buggy after a minute or so, and almost unusable after 10-15.

I also notice that the UI display, when I tap on a surface, takes longer - closer to a second.

If I had to guess, there’s either a memory leak, or perhaps undo/redo history is slowing down the app - SPECIFICALLY when you make a selection, which updates the contextual UI. This could also affect timing for selection specific actions, and would significantly affect multi-selection actions like double tapping.

It feels like the 2nd tap of a double tap is being caught on a hung frame, due to UI or rendering.

Some potential solves tho might be to run input detection on a separate thread from UI or rendering, so that a double-tap that lands on a processing frame is still caught. Ofc “make UI appear faster” or “cleanup memory leak” could work too, but those are potentially huge tasks. Anyway, I’d guess the root issue is the 2nd tap is just being lost. I hope that helps!


Thank you, this is helpful.


Yes this is driving me nuts, just upgraded to new ipad pro and it has been soo frustrating. Faces would flash grey like they are selected but double tapping wasn’t working, realised the flashing grey is part of the apple pencil “hover” feature that is new (at least to me) so maybe also it has something to do with that as it is highlighting a face before the pencil touches the surface.

1 Like

It seems like Shapr3D should hire you on as a consultant, Curiobot! I’ve found the app works as it should within the first few minutes after each restart, too. Thanks for helping dissect this problem. Hopefully we’ll see it addressed in an update soon!

Same issue for me. Helps for a while when closing and reopen design. Quite irritating.

1 Like

Same issue. It’s really slowing down my workflow. I also found that restarting the app makes things better for a little while.

It seems to me that iPadOS 17.1 improves this double tap issue. Do you all see improvement too?

Is this happening when you turn on Isolate?

Hi Istvan,
I am able to double tap to select body with or without isolate. There is a big difference though. When in isolate mode, there is a “flash” that is not seen when isolate is off. This video is with isolate on.

UPDATE: I do not see the double tap to select body “flash” in 5.493 while in isolate mode!

Also having problems with dobbeltapping.
Is it solved?

We are working on afix.

1 Like

How’s that fix going? I’m still having problems with double tap

Hi Muzz,
Does closing the Items sidebar help you double tap to select?

I’ll give that a go. Thanks. Hopefully that helps. I’ve noticed that it seems better since the last iPad OS upgrade.