Edges Selected

If I sketch a rectangle and select its edges, there are 4 noted at bottom of screen. If I push it to be a 3D rectangle and select edges, it has 12 edges, as expected. But if I extrude to create same 3D body (I think) it only has 10 edges. It doesn’t count the 1st edge selected and another one.

Is this a bug or am I unclear on the concept? Thanks

BTW, Wishing you all a Happy & Prosperous New Year

Hi- are you sure you have selected all the edges in the second case?

Please upload a video. It would help a lot

Hi- are you sure you have selected all the edges in the second case?

<<<Thanks for your quick response, Daniel. Yes; I went one by one –
several times. This is brutally simple. In the Extrude case, click on an
edge to select, the display does not show 1 edge selected. It is only after
the 2nd edge is selected, that the display shows 1 edge. If you don’t see
this then I will make a movie for the experience value.

To be more simple, is a square shape pulled to a body, the same exact body
– if it were extruded (given same dimensions)?

Viewing some of the newbie questions/problems, I think that it would be a
good idea to have a Learning / Design Approach guide or white paper.

In my case, I first looked and listened; at all the videos everywhere (at
least twice). Read everything in the forum. Then, on some long airplane
flights, I just worked with every tool and function – often copying the
example. I used a crazy monkey with a shotgun approach. In doing this with
the beta, in fact, I saw several of the bugs later mentioned and fixed. I
didn’t say anything. Sorry! After all, I was just the crazy monkey… From
35 years of software experience, it is always good to have a crazy monkey
on your team.

Not sure if this was mentioned, is that the axes colors get mixed up from
time to time when objects are being transformed. Not sure if I can
reproduce but am sure it happened.

I have now started on a real project; creating a holder for a set of 3
sizes of inexpensive ceramic knives. This is a test project for an bigger,
professional project.

The holder is loosely inspired by this design which I intend to print on my
new Tevo Tornado 3D printer that I bought myself for Christmas.

Finding the modeling of a knife challenging with all the compound curves,
etc. But I only need it to be figuratively and dimensionally accurate. The
holder has to be exact because I will print it. I find that whenever I have
a problem with the model not working out like I want, I go to another
WorkSpace and try a brutally simple example and see if this works. Thus, my
question above… I think that it would be good advice for newbies to
consider following my approach and also to encourage them to model
something that has some interest/importance to them. This is critical as
they will have the motivation to go back and forth learning to acquire

A suggestion is to somehow make the Name of a WorkSpace displayable in the
true work space. When you are flipping between a design (with variations)
and lots of tests, you can easily lose track of where you are. I know how
to Rename a WorkSpace; the problem is to know what you are really working
on at the moment – especially in an environment where you are interrupted
a lot.

Keep up the excellent support.



Hi Tom - great insights, thanks. Hope the holder/knife works out. From the looks of it, there is nothing Shapr wouldn’t handle (sketches, extrusions,
subtractions, replace face maybe) :wink:

As for the white paper: we have started to put together a documentation (it’s not about design approaches, but rather a comprehensive guide to all the tools we have) https://support.shapr3d.com let me know if this is something that helps you :slight_smile:

Please upload a video, I’m having a hard time recreating the problem. They should be the same body, yes.

Edges.shapr (396 KB)




I tried reproducing the problem in a new Workspace — starting with two separate squares and could not do so.

But encl is the original Workspace which shows problem ( I hope). I believe that this body was Extruded up. Ss1;select edge by clicking with Pencil; note nothing displayed at bottom of screen. Ss2; select opposite edge (now 2 edges selected) bottom of screen shows only 1 edge selected. Deselected both edges and selected vertical edge; display now correctly shows 1 edge selected Ss3.

So the problem seems to concern edges on the face that was extruded.

Hope this helps…


And if you continue to select all edges, only 10 edges will be displayed. And they are indeed all 12 selected.


Hi- thanks for the workspace, it will be much easier to investigate like this. I see the problem now, thanks for the report, we will look into what can be behind the issue.

I have redrawn that one line that had the problem (it is always the longer edges of the face from the first picture), the Selection info worked again.