Why is my extrusion sliced into pieces?

It,s not the first time it happens to me. Extrusion produces fully sliced up body (each line is like a cut of a knife). Previous times it had happened, I had to “clean up” completely the drawing to be extruded, leaving only the perimeter lines, which worked out.

Today, I’m not even able to solve the extrusion that way, as the extrusion of a single body is also not working “extrusion failed”. Any ideas as to how to circumvent whatever I am doing wrong?! Thank you very much!

Excuse me, but it doesn’t make sense, I have been working with Shapr for about a year and I usually extrude sketches with intersecting lines. Is this Shapr’s official feedback concerning this as well? This seems top be a bug that happens here and there.

If you are extruding by selecting all the profiles at the same time, they should be united. If you are extruding them one by one, they will not be united automatically.

Thank you, I am extruding as I usually do. All areas at the same time. It shouldn’t slice up, I know. It’s really strange but it stopped my progress today… Should I email support?

Yes please, send the workspace in .shapr format. Or if you can share it here, I’d be happy to take a look.

Here goes the file with the slices right above the sketch from which they were extruded. Next to all, the drawing without internal lines that I couldn’t extrude either. Thank you very much!
Processing: Credit Card System V05.shapr…

This haven’t uploaded successfully, can you try again please?

I am getting a message that “new users can’t attach any files”. I believe this morning the warning was that as a new user I could upload a maximum of one.

now you can

Here it goes… Credit Card System V05.shapr (601.1 KB)

This is what I get:

I made the experiment of selecting - extruding - undoing (each item)to see where the system “breaks”, but about 3 / 4 of the way along “selecting - extruding - undoing”, it starts breaking… I require a single “U” shape part that I have extruded before and is hidden in the doc “Credit Card Wall”.

Tried it with the other sketch too:

Exactly… I can’t do that… it extrudes each area intersected with a line divided. :confused:

My device is an almost brand new ipad pro 1TB only 200GB used, fully updated. Pro business account with Shapr.

Please see the large amount of bodies it generates.

Are you doing it like this? Screen Recording 2021-08-23 at 15.55.57.mov - Google Drive

I can’t do that because if I do, all lines get selected, and instead of getting an “extrusion” prompt, I get a move object prompt. I select one by one each area I need extruded…

Select the “Faces only” filter.

Not working. I don’t see the option you mention “Faces only”. Please see attached image.

While you are dragging the area selection, there are filters on the left. Tap on “bodies only” while dragging.