Windows Updates?

I need to work on a project on my desktop but apparently windows is not up to date and I can’t force it to update to a new version to utilize the cloud saves. I also can’t export as a shapr project as it has the same problem. I’m stuck til’ I can update the windows version. Any suggestions?


The Windows app should always automatically update itself to the latest version, so there’s something going on.

Have you installed the Windows version from the Microsoft Store or from our website? More precisely, do you remember which button did you click on the download page?

If you installed the app from the Store (used the left icon), you should start the Microsoft Store application, search for the Shapr3D app and you’ll get the option to click “Update” on its product page.

If you installed from the website (used the right icon), you could go to “Add or remove programs” (or “Installed apps” on newer Windows versions), find Shapr3D there, go to “Advanced options” and then try “Repair”.

Also, if you are 100% certain that all your designs are saved in the cloud, you could also remove Shapr3D from your desktop and reinstall it. WARNING: any changes that are only saved locally on your desktop machine and not synced to the cloud will be lost!

I have the windows store version. I have tried to get it to update and it just says “open”

I have had this happen in the past. It seems to take a while for windows to realize there is an update.

According to Shapr the app version I have is 5.493.5987.0 #f98b370b

Unfortunately Store is not always as stable as we’d love it to be. You could try these troubleshooting steps listed by Microsoft. – in particular, checking the “Get updates” section within the Library section of the app, if you haven’t already done that.

Again, if you are certain everything is backed up in our cloud, a remove & reinstall is a safe option, everything will be synced back to your machine after you log back again.

I have tried the update section as well. I will try an uninstall.

I uninstalled and re-installed and issue persists. I assume Windows Store just doesn’t have the most current version for some reason. I have installed the most current version from your website and it appears to be working.

That’s strange – according to the Store’s admin interface and the telemetry we see about new installs new users should all be getting the latest version.

Anyway, glad to hear that the website install path worked out. The two releases are completely identical apart from the installation method, so if that works OK for you, there’s no reason to move back to the Store version.

Ha the joys of windows. It’s been a while since I put this thing in the trash. Windows will no longer pass through me.

I’ve had shapr so long I think the only original install option was windows store. I’m happy to use the standalone.