Error selcting sketches after projecting body on plane

I revolved a shape to generate a male thread. So far everything worked ok.
But after trying to project the thread on a plane, I got the outer permiterer of the thread.
I wanted to delete some of the projections to ‘clean up’ the shapes I want to work with.
I select some of the projected sketches, but I keep getting the ‘Something went wrong, no changes were made’ message.
What could be the problem?
Thanks and best regards.

Hi @ecamou Welcome to the Forum.
If you wish to create a 2D Sketch of your Threaded Body there should not be any problems.
However when it comes to removing the continuous lines created by, e.g., the outer Edges of the Thread, it will be necessary to Split the Lines/Curves to remove the offending portions.

The Bolt is Tools > Projected onto a Plane Offset to the rear using Add > Construction Plane > choosing the Offset option:

This shows one of the Continuous Sketches that may need Splitting:

To simplify the situation one alternative would be to remove half of the Bolt prior to Projection:

Leaving a cleaner Sketch that is formed by easily removable individual Lines:

If this is not helpful just shout.

Happy S3Ding.

1 Like

That’s an unhandled error, a bug in our code. Can you please contact We would love to take a look at the issue.


I sent the Shapr3d part file to with some attached photos.

The projection I tried was not from the side of the tread, but from the top of the part. From the axis of the screw as it goes into the hole.

I wanted to confirm that the outer perimeter of the thread (the outmost diameter of the screw) was the right size for the hole it goes into.

I guess that if we project the thread from the side, it will generate a continous spline (the ridge of the thread) in a helix shape all the way from the top to the bottom.

Hope this explains what I intended to do.

Best regards.