'projecting' a closed sketch from body edges


#1

trying to project a closed sketch from a body I created. I no longer have the closed sketch from which I extruded from. Is it possible to recapture these lines in a closed sketch? …‘project’ doesn’t seem to do anything here.


#2

If it is the top of the table that was extruded (and deformed), just tap on it to get in its plane and draw the lines around its periphery. That should get you a closed sketch.

If not the table top, not sure what was extruded…

Have never heard of Reflect?

Why do you need this.

Best,

Tommy


#3

Blockquote Why do you need this.

Blockquote

Because I would like to perform the task as fast and as simply as possible. If it’s super easy to extrude off a closed sketch, it should be just as easy to revert that outline off the body back to a closed sketch. Instead of re-drawing the lines. I just re-drew the closed sketch because I couldn’t fine any user-friendly methods to get back to that closed sketch. Not a huge deal in this application, but what if I have a more complex body and I need to revert to a closed sketch?..Sounds like a real mess. Also, how can you hide a closed sketch that was extruded? The whole reason I deleted it because I simply didn’t want it in the viewer window while I worked.

Blockquote Have never heard of Reflect?

Blockquote

typo: I meant PROJECT in constraints.


#4

You can hide/display sketches via Groups.

Best,

Tommy


#5

OK got it. So basically don’t delete anything, just hide stuff through groups. It sounds impossible/arduous to revert to a closed sketch from a body without re-drawing then, correct?


#6

It seems fairly simple to recreate any closed sketch. Just did a test for a cube in seconds.

!

Extruded a cube, displaced and deleted its sketch.

!

Then go to Bottom view and tap to draw on that face of cube. Draw four lines and you have your sketch back.

When I started using S3D I would keep all the sketches but if you are doing 3D designs, just why do you need them?

Best,

Tommy


#7

I have no features on my Shapr3D like what you just showed. Never have seen a “pen” function, I only get turquoise colors when I click on a face. You have this navy-blue color I’ve never seen on my copy of the software. Interesting. Like, what else am I missing…

According to the app store, I have the latest version. I’m on 3.6.3 (4093). How can I get that functionality in the app? I’m not buying pro until dev and everyone on the other side of the tracks are on the same page. This is whack.

You also have a different menu than I do. What’s going on here? I thought trial users have the same app as pro subscribers?


#8

No conspiracy theory here. I am using the Beta version which has features which should soon be in the production version. You can request to be a Beta tester but sometimes that entails having situations that don’t quite work out. It is a test environment and one can lose work, although I never have. I make sure that all is well backed up. And if you work on a design in the Beta, you (sometimes?) cannot go back to the regular version for a design modified in the Beta. It is a bit like walking on the wild side…

But everything I did in your case could have been done even with a very old version.

Best,

Tommy


#9

alright. the old version has chops? -somebody show me how it’s done then. On the old version please

Nice to see the new version has improvements


#10

I’ve found that once something is extruded, modifying certain aspects is next to impossible in this app. Gotta revert to the 2D sketch plane. That seems to be the path of least resistance in the old version IMO anyway. Obviously I haven’t been using this app very long, there’s some things that are very intuitive and some things that make me want to throw the iPad across the room. I’m no idiot, there’s a decent learning curve & workflow I can easily get into & love about this app, but I hit these unnecessary road blocks involving simple procedures… there’s no need to design software to make it difficult. It’s a creative tool. Would love to stay in that honed-in workflow without hitting a roadblock and then digging into how-to videos (which are dated vs the UI) or then finally creating topic on the forum only to find people are using an entirely different & upgraded version.

EDIT: also tried several times to draw/trace/replicate the closed sketch from a body that I previously deleted. No dice. But nice to know that feature is doable in the new version. Will make sure I never delete anything until then. Thanks