Export stl and obj results differences


When I export a simple drawing and import to prusaslicer i get different results. The stl results in much larger diameter circles while the obj results in slightly more accurate size circles. I have attached screenshots to show. The obj is the one on the right. I have checked and changed inches and millimeters in both export and import. The sizing once printed is off from the design significantly. 1-2mm wrong on circles and more on width and height. Not sure what to do or check.

Here is the design

Hi, that’s weird. What if you reimport the STL into Shapr next to the existing model in your workspace? Does it have the same dimensions?

If your model has the right dimensions after exporting, the printed dimensions will be independent of Shapr3D or the model you are using. It will mainly rely on the slicer settings and the condition of your printer.

That seems like a big problem. Are either of them exporting at the correct dimension!

Not really. The STL exports the overall rectangular dimensions correctly, but the inner circles are larger. The OBJ exports where the circles are closer to the correct dimensions but the rectangle is about 36% smaller. (My guess is the whole object is scaled 36% smaller so the circles are closer to what they should actually be).

Yes i have tried exporting and re-importing them back into Shapr and they all appear to come back correctly, i even have double checked their distances and they are what i entered originally. I have tried different export settings such as ASCII vs. Binary, Inches vs. MM with the same results. I haven’t used any other slicers yet so i may try to download another one and see.

Looks like the OBJ doesn’t even import in Cura Slicer, but the STL does. Although the STL shows different outer dimensions also. should be the 122x24 but showing up as 127x50

Also i tried a few versions of prusaslicer. stable, alpha, new RC1. in the stable the obj’s don’t even open, in the alpha they do, in the RC1 they have scaling issues. not sure if all this helps or not. i am trying to find some pattern in all of it.

If you can upload the models, I can check them out in another software. I’ve worked a lot with Cura even with models exported from Shapr3D and never experienced this issue, it’s strange

Can’t upload any attachments so i shared them here: https://drive.google.com/drive/folders/1z4-ARdoxy33gc6ojkVWLbOaAwQA25D5q?usp=sharing The numerous obj files are exports with trying to set the file with mm or inches to see if it would help scale correctly. stl should have been created in mm. what mainly baffles me is how the outside is correct but the inner circles are twice the size they should be.

Thank you for the exported files, the dimensions of the STL file are shown on the picture below. Are they correct? Please note that currently in Shapr3D circles can only be defined by their radius. Can it be the cause of the doubled inner size?
The three OBJ files have the same exact dimension with a 0.03 x 0.105 mm base. They are pretty small compared to the STL .
Can you please upload the .shapr file?

(sorry for the lame dimensions)

Haha no worries thanks for the help. I uploaded shapr file. At least you are seeing the same issue I’m seeing I think

Yup, STL meets the nominal dimensions, OBJ is way smaller :confused:

Is there some configuration issue I’m not seeing? I feel it’s not a coincidence that when printed the circles print at almost twice the size. 5mm print 10mm.

Regarding the OBJ issue, I think we have to investigate it.

The size of the circles is a different case. You can only define the radius of a circle in Shapr3D, which is set to 5 mm for the smallest one. It results in a 10 mm diameter circle because the radius is the half of the diameter. Can you please describe the issue with the circles?

Nevermind on the circles I was just being me and not thinking