Design scale not the same when exported to slicer

hello again. im trying to be self-sufficient with my designs but i can’t seem to figure it out.

im trying to create a frame for eye protection at work since there is a shortage. what i did was scan the frame and trace it on shapr3d. when i exported the design to Prusa slicer, the scale of model was way too small. i used mm for the design.

is there anything i missed to do? whats the best practice when trying to design replacement models so that the scale is accurate?

thank you very much for your help in advance.

I use Shapr3D to design for 3D printing all the time (maybe a hundred printed models so far). The only time that I get a huge scale difference is if I draw in one unit (in) and slice in a different unit (mm).

Are you sure your design and the slice are both using mm?

yes i have both mm.

Can you share your project file and maybe STL file that you are slicing?

I cant upload because im new :frowning:

I bet the @KPeter_Shapr3D or someone on his team will fix you up soon.

What slicer?

I’ve not used that one. But double-check under Advanced (you have to expand it).

You are exporting STL right?

prusaslicer. thank you

yes… .stl

Sorry missed the Prusa. Latest version? When I forget and send it in inches, it ends up almost too small to see. Otherwise it’s worked flawlessly. You are sure it’s in mm top corner of the drawing before you export?

i did design it in inches BUT have tried to change it to mm. BUT i will try it again later when i get to work.

its hard working on an IPAD then sending it to FB MESSENGER so i can open it on a MBP while there is spotty wi-fi… :man_facepalming:

very thankful with the assistance. i’ve been stuck on this issue for awhile. i shied away from posting questions that may seem to have obvious solutions FOR seasoned users and most of the time people neglect this and new and aspiring guys like me get scorned GENERALLY. but NOT here. very helpful people and i thank you very much.

1 Like

We are all learning…

Try Airdrop for the transfer.

Please forget STL, nobody uses STL voluntarily as output!
For your own 3D printing, please use OBJ as output format.
The quality is much better!

good to know… i will also try that.

so i tried to make sure all that can be MM i changed but still the same outcome. still landing not the same scale/size on the slicer.

also tried exporting as .OBJ and nothing…

one thing ive noticed is that it would ask me that its detecting measurements in inches and if i want to continue with importing it to Prusaslicer AND THEN convert it. when i agree to this, the model ends up way too small…

sorry i still can’t upload the file. wonder how many post’s id have to make to be able to upload. thanks

Usually they are pretty fast at giving you upload ability.

So, yes if it is importing with inches that is not good if it is in mm. At the top right change the drawing to inches and export the STL and see if that gets the slicer to do what you want…

The STL does not include units so it is odd that it would “detect” inches.

Looks like im able to upload now.

I did not another design work and dimension/scale was spot on. Only difference with this PPE file is i traced it from a scanned image while the other that i did was based off actual measurements from a caliper. Could this be my problem?

eyeshield.shapr (1.1 MB)

Your part is only 1.5" long. I imported your file, it’s in inches. I changed units to mm and exported STL. It loads correctly in Prusaslicer. You need to scale the part larger to the correct size.

Thanks. So this confirms my approach to designing from a photo/scanned image is wrong. I thought scanning the item will give me accurate 1:1 dimensions

Any suggestions on how i can go about recreating a model from a scanned image?

I think scaling from prusaslicer wont work or id have to print multiple times to get close to accurate scale?