Export to svg has overlapping lines

I have designed a stair tread for a spiral staircase to be cut out with a cnc plasma cutter.
The pattern was somewhat complex and likely had overlapping lines so once my part was a complete body, I deleted the sketch and projected a sketch of the body.

I export via SVG and import into sheetcam and it’s says there were duplicate lines that were deleted. These cause some loops to be divided into individual lines or have multiple start points on a single cut.

The white lines in this image are the problem. I thought that by projecting the sketch from a body there would not be such lines.

Any help would be greatly appreciated! Thanks

Also this design takes a long time to load and the processing required drains the battery noticeably.


Thanks for reaching out, we are happy to look in to the issue. If you can send us the workspace, that would help a lot. Please send it directly to me (alexander.pavlov@shapr3d.com) or upload it here as a reply.

By any chance, have you tired the same process, but with exporting it to dxf?

I have tried export into dxf and it looks very different when I import into sheetcam. Sheetcam uses dxf but I have not had any luck with the dxf exports from shapr3d.

The SVG exports have been working great up until this problem, which I imagine is operator error. It appears that when I project the body, it places 3 identical sketches on top of each other.
I am assuming that if I trim every single line twice, that it may work. But surly there is a better way.

Im not sure how to save or send the workspace but I am working on it.

Thank you.

I emailed you the workspace, and I encountered a bug in the process. After sending the email, the shapr3d pop up giving the option to send via mail, would not close. Eventually it did close.
Then I was in able to exit my workspace, I was tapping the button to go back to designs page, with no luck. I ended up turning off the iPad and back on to get shapr3d to close.

Thank you


Thanks for sending over the workspace. It seems that the issue is not with the SVG or DXF export. You can project only the face of the body and in that case you can avoid generating the duplicated lines. I’ve sent you a screen recording of the steps as a reply to the e-mail. Let me know if that solves the question.

1 Like

Yes! Thank you so much. I was highlighting the whole body from the layer menu, and I should only be highlighting one face.
I am positive this will solve my issue when I import into sheetcam.

It work’s flawlessly.
Thank you for the quick response.
Can’t believe I didn’t realize what I was doing.

Sounds great! I’m happy that it helped :wink: