Bug in .svg export

There is a bug in the .svg export at least when imported to shaper origin.

When you import into Shaper Origin some of lines are not connected leaving open paths even though they are connected (yes “join segments” is selected).

When will a fix be deployed?

Hi,

We would be happy to take a closer look to see what can be behind the issue. Can you share your workspace here on the forum or with me via alexander.pavlov@shapr3d.com?

Please see ticket 58363, I posted here for more visibility

I have had a similar issue when importing into sheetcam. I only need the 2d sketch to make my cuts btw. How I fixed it is by extruding the sketch into a body, delete the original sketch, then project one side of the body to the whichever axis you are working on. It will give you your solid closed line when exporting in .svg

Thanks for the tip, that was my next step to try. Just got totally frustrated and wasted so much time trying to export a simple shape I had to walk away from it…

I have just made a habit of extruding and projecting each sketch, then deleting or hiding the original and the body. No troubles since, even with complex shapes.
I have no doubt they will soon fix this export issue and the extra steps won’t be needed.

The mirror bug can be worked around as well by extruding, mirror, combine, project.

Combine, not sure what function that is. Can you just extrude and export as .svg?

Also I don’t get it, if you project the body are we not just making a copy of the same lines with the same connection points which are randomly not connected in the exported .svg?

I meant to say union, instead of combine.
I think program if failing to connect all lines in the sketch when exporting to .svg, but somehow the projected line is read as a single line when exported. I imagine it is just a bug that will be fixed soon.

I have used this method on everything I have drawn on shapr3d to cut out on the CNC plasma cutter, otherwise the lines won’t all be connected when imported into sheetcam.

I have tried multiple things with no luck, I am actually in software validation for industrial controls - I am the technical lead

I am not going to validate this software, I do it 45-50hrs a week, a lot of times the designers push it back on us to do all this testing because they are lazy and think it is out job to find the issue, when this occurs it’s almost always because the did not update the Epic with enough information ad they did not have code reviews and thinly thought out engineering test cases that they did not do in the first place.

I am not saying this is going on here but I am saying that this .svg feature was released half baked, the basic functionality of a .Svg does not work and this is not a Shaper Origin issue.

So now I am forced to
a. Purchase another program like Fusion and dump Shpr3d - which is too bad because I really like it for the most part
b. Export , import to another program, export to save to local file, import into Shaperhub, download to Shaper Origin… No thanks
c. Return the Shaper Origin, I have until the 31’st but I doubt I will do that

We have plenty of happy customers using Shaper Origin, we will look into this issue, and fix it if the problem is on our side.

1 Like

Thats good to hear, I guess they are ok with a workaround I probably would be as well if it was simple…

One other note on the bug, I did an export of a new design this time selecting “include sketches “ ( i think thats what its called) in addition to the other setting exported as .svg, uploaded it to shaper hub and all the lines were connected, working as expected.

I thought I was on to something so I re-exported the original file that was having the issue but no luck, same issue as before for that file. Unconnected lines in .svg even though connected in shapr3d

hello Istvan

I have been spending a lot of time lately researching your product, Which seems to be the most user-friendly 3-D cad system that has ever been developed. I have been very involved with the CAD industry since the early 1980s, and have always been frustrated by the complexities of 3-D.

I recently purchased the iPad Pro and Apple Pencil specifically to be able to do CAD drawings, mostly to design for fabrication using my Shaper origin.
. I am happy to read that you have many customers who use your product for SO,
I’m very close to committing to an annual fee,
but I have been concerned about this thread I’ve been reading from a woodworker trying to use Shapr3d for his Shaper origin, and seems to be very frustrated. I hope that you can resolve his issues.
Without a good clean SVG export to SO, committing to your product doesn’t make sense for me.

thank you for developing such a program and associated customer education & support system.

I will keep reading the forum and hope for eventual good news.

All the Best,
Bill Garbus
Arcisan Studio | New Canaan, CT

1 Like

Hi @arcisancad , Shaper Origin is fully supported. You should not have any issues with it. If you do, and the issue is on our side, we will fix it asap.

1 Like

hi Istvan

thanks for your reassurance and very quick reply!

All the Best,
Bill Garbus
architect & furniture designer/maker
Arcisan Studio
New Canaan, CT USA
::::::::: :::::::: :::::::: ::::::::

2 Likes