Extrude imported dwg file and other questions

Hello. I’m very new to Shapr3D.
My work involves drawing existing buildings and working on them in 3D. I do this on an iPad Pro using the Apple Pencil and after trying for a while I have some questions:

  1. Once I’ve imported a plan to Shapr3D from a .dwg file, how do I extrude the walls so they’re in 3D? I tried to trace the walls on the imported plan so I could extrude them, but this doesn’t seem to work.

  2. Once the plan is imported, if I exit that project and try to open it again, the whole screen goes foggy and there’s a blue circle in the middle with the Shapr3D logo in it. It just freezes that way. All I can do is shut down the app and reopen it, but if I try to open that project again, the same thing happens.

  3. How do I select a whole plan that is made up of many lines? Trying to tap on each line is very tedious and if I make one mistake, I have to start the whole process over again. Is there a tool for selecting a group of objects?

  4. I modified the .dwg file in AutoCAD Mobile (on the iPad Pro) and tried to import it, but there’s nothing there. The “Layers” menu that appears at the side of the screen shows 0 for sketches and 0 for Defpoints.

Sorry if any of this is covered in the tutorials, but I wasn’t able to find anything.

Thank you in advance for your help!

Hi - welcome to the forum! :slight_smile:

  1. Once imported, go to 3d view, select a closed sketch and extrude it. If it doesn’t work, can you please send a video of the problem

  2. If you send the dwg file to support@shapr3d.com we can investigate the issue. Hard to tell from this description, but probably we can fix the workspace.

  3. Double tap or long tap any line and it will select all connected sketches
    This article has some visual aides to help you: https://support.shapr3d.com/hc/en-us/articles/360009920039-Selecting-and-moving-sketches

  4. Again, can you please send it to support@shapr3d.com. There are certain geometry that might cause some problems, but not on this scale. Please send it and we will make sure it works.

Hello Daniel.

Thanks! And thank you for replying so quickly.

  1. The drawing that is imported is just lines, no solids, so I can’t extrude. I’m uploading a screenshot.

  2. I deleted this and tried again. It took a few minutes to import, but now I can open it. This is the file that I uploaded the screenshot from.

  3. Thank you for this, but this video shows the problem I have - not all the object is selected, just the top part.

  4. I’ll send the file to the support address.

Thanks again.

Thanks - would look at the file, but can’t seem to find it. When did you send it? If possible can you also send it to daniel@shapr3d.com as well

I’m sending the file and the screenshot I mentioned now.

Got it :slight_smile: Thanks. I’ll speak with the devs about the file - not sure what the problem is.

As for the video you attached - double tap the orientation cube and get into 3D view. You can only select closed sketches in 3D view. Recorded a short video:

  1. Select multiple sketches with double-tap or long tap (not related, but it was asked earlier and thought I show you)

  2. Getting into 3D view (in this case rotating the view with one finger)

Thanks. I tried to open the project, but I get that white screen again. Here’s a video:
(nope, can’t upload it. I get a message saying “Sorry new users can’t upload videos”).
So I guess you’ll have to take my word for it! :grinning: Should I send it to the support e-mail address?

I thought that maybe the problem was that I’ve been trying to open a file that I had first imported into AutoCAD Mobile and then tried to open in Shapr3D. I tried importing the original file, as I received it from someone who had created it in AutoCAD desktop, but I can’t open that one either. I get the "white screen of death.

When I first imported the file (I could access it then), I used the Extrude command and tapped on the walls, but nothing happened. But if I tapped on an area within the walls, I could extrude it.

Yes - please send the to support@shapr3d.com (or I’ve upgraded your account to member, so you should be able to upload smaller videos here as well)

We will investigate the DWG file - will get back to you latest Monday afternoon.


You can only extrude closed sketches - probably in your case the walls are not properly closed. Make it a closed sketch and extrude it.

Will be in touch about the DWG file

Thanks for the upgrade! I’ll send the file to that address. I wasn’t able to attach it here.

1 Like

Hey Fred

We took a look at your file, and managed to make it importable to Shapr3D (sent it over in email).

The problem is still under investigation, we will figure out in the next few weeks. Until then, hopefully you can use the file I’ve sent over :slight_smile: