Can’t import DWG or DXF

Hello,

I’m new to Shapr3d, still using the trail. I am trying to import DWG/DXF files, but when I choose import and browse to the file it is greyed out and will not let me import them. No errors or warning, I can’t even select a file. Is this a glitch or am I doing something wrong? I am trying to import from Google Drive.

1 Like

Jimmy, I believe importing files is limited to the subscription version. The trial version allows you to create designs, up to 3 I believe, then, subsequent designs require the pro version. McD

It’s the full version. You get a 14 day trail before they charge you unless you cancel, but it has all the full subscription features, so there should be no limitation on what I can import/export.

Jimmy, then my bad. I don’t know why. Sorry.

Hi @TinkerBrained, can you please try saving it to the files app and opening it from there?

Okay, saving to Files app seems to be working. Is support planned for Google Drive in the future? Thanks!

It is supported, unfortunately it’s a bug in Google Drive… Google’s iOS apps tend to be… not very high quality… :frowning:

1 Like

Thats a truth:) Gmail still doesn´t support split view, and don´t let me start on the google sheets and docs apps:P

1 Like

When I try to import DWG or DXF it seems to work sometimes and other times not. I don’t understand why? I have moved files to iCloud Drive and have tried copying to local folder on iPad but when I import it pops up message to manage imported layers in item manager and when I look at layers it says 0 sketches on each layer. What am I doing wrong?

Thanks
Jeff

Same issue. Appears to import but no files or layers with imported item in it. I tried importing into a brand new shaper project but nothing actual imports a DWG.

I am importing from iCloud downloads directory

Jim

If you could send the file to support@shapr3d.com we would love to take a look.

Sent a couple of files just now to the support email

Jim

Thank you, we will take a look and get back to you in email.

The problem seems to be that it just…takes…a…while… and seems to be hung so I gave up in past.

Hi Jam, I’m having the same issue trying to import a dwg or dxf file. Nothing seems to import! Did you end up changing the way the AutoCAD file was saved(I.e. version?). As the app does not support text, it was some words that I was trying to import. I was then going to project them onto the surface of my model. It’s frustrating me… can’t see what I’m doing wrong?!?

Hi, can you please check if the drawing in AutoCAD is placed near to the origin of the coordinate system? When importing, Shapr3D checks a specific are for the data and if it is placed outside of this area, the drawing is imported as an empty or faulty file.
If your case is different, please upload the file here or contact us at support@shapr3d.com, we are happy to take a look at it :slight_smile:

Can you give us some bullet point rules regarding import and export of DXF files? What you just mentioned regarding origin would be a good start.
I have had a problem exporting, so much so that I had to redraw in another program before sending it off to a a fabricator. I did a test drawing of a simple circle and a simple square on the front plane and tried to export. I only got the circle. So for me, the export seems to be broken but maybe I am not observing some rules of which I am unaware (like what plane must contain the sketch).

OK, this is what I have discovered so far… If I just draw any basic shape (on the origin point) in AutoCAD, when I import it into Shapr3D it appears!.. Perfect! However, if I write some text in AutoCAD and place it on the origin, it appears the app can’t see the layer? (See screenshot)
I tried drawing a circle and writing text on the inside, and just the circle appeared when I imported it. Question… Do I need to generate my text file in a particular way or do something else to it for Shapr3D to recognise it??

I will try to get back to this topic in the following days with a small brief about the export/import tricks to help you in the future.
@Lockpro can you please describe what problems did you have?

1 Like

@KPeter_Shapr3D said “I will try to get back to this topic in the following days with a small brief about the export/import tricks to help you in the future.
@Lockpro can you please describe what problems did you have?”

I just posted about my issue as a separate topic, however here it is again.
To test why my sketches were not able to be read by my simple 2D Cad program (DeltaCad, been using it for many many years) I created a simple sketch on the front plane. It is simply a circle and a square. When I try to open the DXF in either DeltaCad, FreeCad, or eDrawings, all I get is a horizontal line and the circle. See the images.

This happens when exported from either the iPad or the Mac desktop BETA.