Having trouble with sweep

I am able to use the sweep command against a spline that only has on point, but when I add more it doesn’t work. This is going off the first steps of the make a kayak tutorial on YouTube.

hey! Can you share the current state of your process, please? Some screenshots or a screen recording would be super helpful!

Sorry did try doing that yesterday but was having trouble, hopefully this works!

I see, thanks for sharing. The bend of the curve is too tight for the cross-section, it would result in a self-intersecting body where the solid-state cannot be maintained. Please make the cross-section shorter to make sure it can be swept through the guide.


I’m surprised that @sjmartian’s design didn’t work.

I recreated the profile but pushed it to the extreme in my video and it worked just fine.
- note how tight my bends are.

1 Like

…and in this video I copied the profiles as accurately as I could from the image…

1 Like

Could it possibly be the size of my path? The overall length is only 60mm, as I’m modelling a small surfboard figure. Would you recommend working at a larger scale and scaling down once complete?

1 Like

The size should not matter until you model way below millimeters. Can you please upload the Shapr3D design?

1 Like

I am unsure how to do this, I don’t have the premium version and can’t save in Shapr3d native format, what would be the best way for me to save this?

1 Like

I tried to replicate your profiles based on the image you posted.

Could you possible screen shot the ‘TOP’ view and "FRONT’ view with the nodes of both splines active so that I can replicate exactly your profiles?

I’ve recreated the shape myself and it seems to be working now, I’m unsure if this was due to the way it was originally created. Problems seems to be solved now, thanks for your help :slight_smile:

1 Like

You’re very welcome. Happy it worked out for you :slightly_smiling_face: