How can I get my edges rounded?

Hello there, I hope it is ok to post here, as long as I am still evaluating if I can achieve the desired skills in 3D modelling with shapr 3D. I did not yet switch to pro plan, I am a total beginner with 3D modelling, never have tried to model anything more than a cube with blender :slight_smile:

Now shapr 3D looked so easy to me, that I have gathered the courage to give it a try.

So far I have spent around 3 days now, trying to build a kitchen knive from an image. So far it is not that bad I find, but I really could not solve to get the knifes grip rounded. I have really tried a lot.

From that point, it is really impressive how simple it is to model with shapr 3D.

The best results I achieved with sweeping a shape along the grips path. But somehow this is not very clean. I guess it is because my base sketch is not accurate enough.

Is there any advice how I can achieve to get the grips edges rounded up accurate? Without that messy results?

Many thanks in advance for any help.

1 Like


I used the ‘chamfer/fillet’ tool to get this result… (fase/verrundung)


Hello Steve,

thank you for providing those examples.

When I try to do that, I get that errormessage saying like „the object is not valid“

This must be related to the way I sketch I guess? Is there any rule how many points or steps a curve must have or not have?


1 Like

Have you tried typing in the dimension?

If you attempt to bevel further than the bounds of the body then you will get that error message.

It occasionally happens to me when I use my track pad and am not able to drag the bevel accurately.

Instead, try clicking the dimension box and type in the dimension you require.

Selecting all the edges to fillet could also help, from just the look of it, I think it fails on the pointy “corner”.

1 Like

Don’t know why @dusticelli’s failed at that ‘pointy’ corner yet mine worked out just fine.

You selected that edge too, and filleted the two together.

1 Like

The resolution of a tool that you can apply with the dual-sided arrow are connected to the grid resolution you can see in the upper right corner. On the screenshot, the grid resolution is 50 mm which seems to be almost the same as the thickness of the handle. Therefore, the smallest step in the fillet radius may be somewhere around or even bigger than the thickness of the entire part.

Please give it a try zooming in, it will result in a finer grid and tool-step resolution.


That’s exactly what happens to me. When using the trackpad I just can’t seem to drag the chamfer out accurately unless I zoom in.

In most cases it’s for the reason you stated regarding the grid resolution,
However, on occasion, even with the body depth larger than the grid resolution I experience issues.
It’s usually because my fingers don’t work well with the trackpad on my MacBook Air.
I almost always have my pen and surface connected and don’t experience the same issues using the pen.

Whenever I come across this issue and don’t wish to zoom in I just type the figure into the box instead.

Yes, I did. However…

…it works for me even if I select them individually.

The results are slightly different of course with a more rounded contour when the edges are chamfered separately.

1 Like

Many thanks to everybody. By zooming in I could use the fillet tool. The corner is no problem though.

What I still don’t understand is about the other way I tried. When using the sweeping tool, it seems like all the side faces built from my sketches extrusion are somehow like uneven. And so the result from the sweep will be messy.

Isn‘t there a way to, let’s say, clean up sketched lines somehow, to have the extruded side faces smooth?


Finally here is my first result as a quick render with Keyshot. It is not too bad I think.

I would not expect that I can gain such a result in that short time as a total newbie in 3D modelling. So this absolutely speaks pro shapr 3D.

But I have another question regarding export files. I hope it is ok to post it here in the same thread.

When exporting as obj file, the model will be kind of microscopic. :slight_smile: as I have modelled it in 1:1 with a length of 16cm, as an obj file it is 0,16 MM lenght.

That’s strange. STEP file is ok and 1:1 but obj not. Why?


Looks incredible! Keyshot renders beautifully.

Series Campillo, 12cm Kitchen Knife, GH1002 ???


Haha, yes. Good investigation! :smiley:

But this should be the GH1001 which is overall 20cm, But the model I made, I did not adjust the sizes accurately. I used the diameter of the circles as reference. I already learned, to better use the overall length to use as size reference.


Aha. I had guessed the model based on the relative position of the rivets in the handle.

In any case, the final model and rendering looks fantastic!

Thank you Steve, I took only the diameter of the rivets as the reference, and of course this isn’t a good idea, as it isn’t accurate enough, resulting in the loss of 3-4cm in the total length. :sweat_smile:

I think any length distance (like the one you guessed) would be better as an overall reference.