HP ZBook X2 compatible?

HI, I have a ZBook X2 G4 running Win 10 x64 that I use to do all my sketching and designing. I need to get into 3d Modeling for 3d Printed projects and came across Shapr3d. Though, in theory, it seems as intuitive as the sales pitch and reviews say, but the productivity seems far from par. The program is extreeeeeemely slow/laggy with regards creating new shapes, moving the camera, and even simply selecting and moving or changing a shape. Certain features like wiggling the pen to change from arc to line just don’t work (yes, it’s set to automatic). Other things like rotating a circle sketch on any axes just doesn’t work even though the parameters (numerical degrees and directional dashes line) reflect the change. If I have two rings inside of each other for extrusion, making a ring mm thick, it’s nearly impossible to select the outer ring from the inner ring, I think mainly because of the lag. I have no other programs (Illustrator or Photoshop) open that might contend with processing power or memory. I just have Shapr3d tutorials running on Youtube via Chrome, and itunes occasionally for background music. Can anyone explain if maybe my PC is an exception that’s not supported, or at least why it’s having this much trouble? Any time and assistance would be deeply appreciated!
PC Specs:
Win Ver: 20H2 (OS Build 19042.1466)
Processor: Intel(R) Core™ i7-8550U CPU @ 1.80GHz 1.99 GHz
Ram: 32GB
Pen and touch support with 10 touch points

It should work well with that pc specs. I run shapr3d on iPad 9, just 3 gb of ram , it work so smooth… or perhaps the problem on your vga card

That’s why I was wondering. . . Most, if not all, of the demo vids Ive come across are apple based products. Even though the product is technically supported, I just don’t know how confident that is. I don’t know if this will help reveal the issue, but the video card I have is
Nvidia Quadro M620
Total Available Graphics Memory: 18.389gb
Dedicated Video Memory: 2.048gb GDDR5
Shared System Memory: 16.34gb

These are very very very basic sketches Im dealing with… a (singular) circle. Thats all. So, it’s (imo) not a matter of the project size or anything. I know that wasn’t addressed, but figured I’d throw it out there.

Yeah…your pc specs actually “monster” compare to iPad 9. You need to ask shapr3d ceo maybe….is there incompactability with certain windows pc…

Your machine should be perfectly capable of running Shapr3D smoothly, especially with simple designs. Here are the official requirements for compatible devices, but we routinely test with similar machines and they work just fine. Would you mind running DxDiag and sending the results to me, or through a support request here? I short screen recording of the bugs/lag you see would also be awesome (though recording can make the lagging worse in some cases).

One more question: are you using the app with pen & touch or with the mouse?

Both. If at my desk, Ill have my mouse/keyboard plugged in, but will alternate between keyboard/mouse and pen/fingers. Howwever, I was able to narrow it down to 3 things: 1.) I can’t have the unit plugged into another monitor. I don’t have this with any other program, app, or game, so I am very certain it’s not the video card or anything. 2.) I cannot have a web browser open. Whether it’s Firefox, MS Edge, or Chrome, Shapr 3d slows to a grinding halt if a web browser is open. Again, I’ve only been able to make such a connection with with Shapr3D. Not other program, app, or game has had this issue. 3.) since a web browser is out, I tried to resort to the Youtube App to watch the beginner tutorial Series on Shapr3 channel… BUT it does the same thing.

So: No second monitor, no web browser, and no Youtube = a smooth Shapr3D experience,
Though I isolated the issues, I don’t think these are solutions :frowning:

PS, Sorry for the delayed response

Thanks for the info! Just to clarify: the app slows down if a browser is open OR an external monitor is plugged in (so these do not need to happen at the same time?)

The problem might have something to do with the interplay of the GPU driver and the app: we haven’t seen anything similar so far on other devices. As far as I know, HP ZBook X2 is one of those devices that switches back & forth between the discreet GPU and the integrated one, depending on the need for computing power or power saving, and we’ve seen problems with devices like that before, though they were mostly stability issues and not about performance.

Having the DXDiag output (see the instructions in my previous post) would help a ton – that way we could identify the exact card and driver version which could help us pinpoint the problem or reach out to the vendor. It’d be great to run it three times and save the output for all:

  1. App is running smoothly
  2. Slowdown because of a web browser
  3. Slowdown because of an external screen

It’d also be great to know the method you use for attaching an external screen: is it through HDMI, the Thunderbolt port directly or through a dock?

1 Like

Thank you very much for the follow up. Yes, “or”. and the HDMI is plugged in using the top USB-C port of the two on the side of my ZBook. So it HDMI (Monitor) to USB-C (Zbook) These are great questions and I’ll try to fulfill all tests by the end of the day 6pm pst (currently 11:40am pst). Technology is rising against me right now as I’m experiencing completely unrelated Laser Engraver issues that are eating up my time troubleshooting. My priority is the laser machine, but Ill do my best to get the info you need. I really appreciate your help and I thank you very very very much.

1 Like



Sorry for the delay once again.
Im attaching the results.
1.) One with the browser open while working with Shapr3d, but the HDMI is disconnected
2.) One with the HDMI connected while working with Shapr3d, but Browser is closed
3.) And One where browser is closed and HDMI is disconnected and Shapr3d just runs so smooth.

Please know that in all 3 instances I have 2 docks connected to the ZBook. One USB 3.0 and One in Thunderbolt 3.0 (USB-C). I would be concerned that they may affect the results, however Shapr3d works great and smooth as long as HDMI is disconnected and Browser is closed, even if docks are connected.

Also, the effect is not stacking. In other words, it lags just the same if I have both the HDMI connected and Browser open as it does with just one.

EDIT ~ Additional thought: two things I wanted to mention. As mentioned earlier, the HDMI is connected using an HDMI (Monitor) to UCB-C (Zbook) cable. But the same problem occurs when connecting using HDMI to HDMI, as the Zbook does have an HDMI Port.
The second thing was to note that I have not tried connecting the Monitor to the Dock since installing Shapr3D. Im 90% the doc has either a USB-C, HDMI micro (maybe mini), or HDMI port. It’d be difficult to get to, but if it’ll help establish a basis, then let me know (b^_^)b

Thank you!! Deeply appreciated :slight_smile:

1 Like

Thanks for the info! We are looking into it and we will keep you posted about the results or if we have further questions.

1 Like

:+1: :+1: Sounds good. Thank you!