Laggy on Desktop

I installed Shapr3d on my desktop and the application is supper laggy.
Are there any settings I can change to make sure the application runs smooth and fast?

thanks a bunch for any help and advice,
appreciate it!

I also wanted to mention. I tried this time on a second 3D Workstation of mine, and unfortunately, it’s soo laggy, that with all the love I have for Shapr3D, this would be the reason to not continuiing using the software. I just can’t work with it if it’s soo laggy.

Can you provide further details? Computer configuration and more details about when and how the performance issue occurs would be really helpful.

Shapr3d should run on that machine smooth and without any issues.
Any clue what issue could cause that problem?

It’s basically lagging all the time. There is no specific tool I use, it’s constant.

please see below all my specs.

Operating System: Windows 11 Pro 64-bit (10.0, Build 22621) (22621.ni_release.220506-1250)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Precision 3650 Tower
BIOS: 1.21.0 (type: UEFI)
Processor: 11th Gen Intel(R) Core™ i9-11900 @ 2.50GHz (16 CPUs), ~2.5GHz
Memory: 131072MB RAM
Available OS Memory: 130798MB RAM
Page File: 26497MB used, 112491MB available
Windows Dir: C:\windows
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, no HDCP
Microsoft Graphics Hybrid: Supported
DirectX Database Version: 1.4.9
DxDiag Version: 10.00.22621.0001 64bit Unicode

Display Devices

       Card name: NVIDIA RTX A4000
    Manufacturer: NVIDIA
       Chip type: NVIDIA RTX A4000
        DAC type: Integrated RAMDAC
     Device Type: Full Device (POST)
      Device Key: Enum\PCI\VEN_10DE&DEV_24B0&SUBSYS_14AD1028&REV_A1
   Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER] 

Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 81581 MB
Dedicated Memory: 16183 MB
Shared Memory: 65398 MB
Current Mode: 3440 x 1440 (32 bit) (60Hz)
HDR Support: Not Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.639648,0.330078), Green(0.299805,0.599609), Blue(0.150391,0.059570), White Point(0.312500,0.329102)
Display Luminance: Min Luminance = 0.500000, Max Luminance = 270.000000, MaxFullFrameLuminance = 270.000000
Monitor Name: Generic PnP Monitor
Monitor Model: Acer X34
Monitor Id: ACR0450
Native Mode: 3440 x 1440(p) (59.973Hz)
Output Type: Displayport External
Monitor Capabilities: HDR Not Supported
Display Pixel Format: DISPLAYCONFIG_PIXELFORMAT_32BPP
Advanced Color: Not Supported

Could you open a support ticket, and attach the problematic workspace?

https://support.shapr3d.com/hc/en-us/requests/new

I have a quite a high spec laptop and also encounter a lot of lagging too. Lots of little delays between what i click and something happening. Sometimes I have to click things 3 or 4 times before anything happens. I’m assuming performance will improve in time as product improves. I think there’s probably memory leakage somewhere as i have to restart my computer and then performance improves for a little while. But yes the lag always returns.

The one saving grace is the software hasn’t crashed a single time and I havent lost any work which would happen in other CAD applications I’ve used.

Hi Simon,
Does closing the Items sidebar help in your case? @Jason42 made an excellent discovery! I almost always have that sidebar closed now and it does help!

Perhaps. I did try it yesterday for a bit and think I noticed an improvement. However I kind of always need the side bar open as have to turn visibility on /off for items, or when renaming the bodies / sketches… I My current design has over 30 sketches and 30 bodies in it so I’m constantly needing access to it.

However I’ll keep my eye on it tonight when I get back from work and start using it and let you know… Thanks

I would like to keep the Item sidebar open more myself, but for sketching and modeling, keeping it closed seems to work a lot better.

My “normal” workflow now is: keep the sidebar closed, then when I need it (renaming, finding an item, digging into nested folders, etc.) open it, do my “items business” then close it. When I forget to close it, I am reminded pretty quickly when I try to select a body and double tap does not work.

This is a terrible workflow, but I can sketch and model. I hope they fix the problem(s) soon.

1 Like

I’m running an i7 (nothing special) and 32g of ram, leave several programs open and no problems with Shapr.

Have you tuned your processes? Cleaned out the start up? There is an art to tuning Win-Ders. :laughing:

First open ctrl-alt-del open Taskman. Disable all unnecessary start up items. Your printer/scanner doesn’t need to be running waiting for you to do something like a dog wagging it’s tail waiting for master to come home from work and feed him. :rofl:

Then go to the search box > type msconfig
Select System Configuration > go to the Services tab.
Select and put a check mark on “Hide all Microsoft services” > Click Disable all.
Go to Startup tab > Open Task Manager > Disable all the unnecessary services running there. Restart your computer.

This will decrease boot times and improve memory function.

Also disable drive indexing. Unless you are a court clerk or do a LOT or searches on your machine it is unnecessary and takes clock cycles when files change.

Select Task Manager’s Details tab. Then right-click the EXE process for Shapr select Set priority. Choose a Realtime, High, Above Normal, Normal, Below Normal, or Low option on the Set priority menu.

Open Windows event viewer ( eventvwr in search). You can leave it open in the background while running Shapr and see if any events are interfering.

Sometimes this kind of intensive tuning can lead to finding malware you didn’t know you had; Processes causing bottlenecks etc.

Make sure you vid driver is up to date.

If you already knew or did all this, then never mind. :smiley:

Hi @Oregonerd,

Thanks for your comments. Personally, I’m on M2 iPad Pro with 16G Ram. I don’t see any difference in performance with Shapr3d if I have some other apps open. I see a big difference in the usability when Shapr3d Item sidebar is open.

Do you usually have that Item sidebar open? If not, could you try leaving it open to see if your good performance and usability is impacted?

Thanks - Unfortunately I haven’t got time to tune my machine to suit one specific application that seems to have memory leaks / bugs in it. All my other applications have no issues and respond snappily. Shapr3D need to address this as people on trials are going to get frustrated with the product and dump it which will be a shame.

Obviously i have no idea how widespread the problem is. But my machine is no slouch and it feels like I’m maxing out my memory whenever I run Shapre3D. The tip to close the sidebar has made a bit of a difference, but again I’m still running at at least 80% inefficiency using the product at the mo. Everything’s taking way longer than it should. However the tool is so good I’ll forgive it right now, and know the team will get these problems sorted soon (fingers crossed).

I get this might be easier said then done with all the different platforms graphics cards and Operating Systems around but it is kind of essential that the user experience is consistent for everyone. The interface should be responsive and snappy by default, which people expect from modern apps these days.

1 Like

I’m running the Shapr beta (history based) on a middle of the road $1400 Cyberpower PC. I usually build my own systems but video cards couldn’t be bought for reasonable prices in 2020. I spent $600 less than what they were asking for my target video card and it came with pretty much the card I wanted.

Shapr runs great. Side bar or no, history bar open as well. I almost always have a browser open with too many tabs, Corel Draw is open, Thunderbird mail and sometimes Adobe photoshop + Shapr. I leave them all open and play Fallout 76. I lock the system at night wake it up with all still running and Shapr works great.

The only time I have a problem is when Shapr updates during it’s startup. Sometimes it gets a bit dodgy, strange behaviors. Reboot always resolves it.

I don’t run antivirus or malware software. Haven’t for 20 years. I know how to stay out of trouble.

I also have standard version of shapr running on my low spec Surface pro 6. Again it also works great… with Corel, Thunderbird, Firefox with 20 tabs…only 8 gigs of Ram.

No complaints about performance here.

Thank you, this is extremely valuable feedback, we’re investigating the issue.

Here are the specs for my laptop. As you can see - no slouch

Performance seems better after last update. Much snappier. Still have to do more designing to see if it holds. But so far so good.

Excellent. We are still working on performance improvements. Thank you for your patience.

1 Like