Import compatibility

Great work on the macOS beta – it’s definitely my favourite CAD software on the Mac based on my initial usage. However, I’ve had serious compatibility issues with importing files that unfortunately mean that I’m unable to use it for most projects at the moment.

I’ve tried importing both a STEP file and a DWG file and neither has worked correctly. For the STEP file, it mostly looks ok but has some random planes cutting through the model. It’s not trivial to fix these issues. It was also very slow to import the first time (many minutes).

For the DWG file, the import shows up blank. If I look in the layers list, all layers are shown but they have a red lightning bolt symbol next to them. If I click on it, a tool tip appears saying:

Empty or Unsupported Layer
This layer is empty or doesn’t contain any supported geometries

Both of these files have imported without issue (or without major issues) into other software – e.g. SketchUp, BricsCAD, TurboCAD and eDrawings – and I don’t think contain any particularly advanced features.

I’m happy to share the files privately if helpful. I know working on import compatibility is not the most exciting thing but it’s absolutely critical in order to use Shapr3D in a production environment.

Hi @pglennie, we would love to take a look at the files if possible. Where are those files coming from?

The files have been provided by third-parties we are working with. The DWG was an export from AutoCAD, I’m not sure about the software used to product the STEP file. What’s the best way to share them with you? I’d rather not share the files on a public forum

If you could send them to that would be super helpful.

Sure, I’ve just sent them. Thanks for looking into this

1 Like