Is this a bug or feature?

Trying too add a line 180mm, but with the measure tool open it inputs a higher number.

Hey, please share the version of Shapr3D you’re currently using, along with a screen recording of the issue. In your recording, enable the display of mouse clicks and keyboard presses in the Settings of Shapr3D.

Could you additionally describe your workflow, particularly the sequence in which you use the measure tool and sketching?

Hi KPeter,

macOS Sonoma 14.3.1

Shapr3D Version 5.541.0 (6373)

I left Measure tool open and wanted to add a sketch line of 180mm, with the measure tool open it creates a far bigger number.

Quicktime recorded the clicks but not my keypresses even though turned on.

Thank you for the video, we are checking this case. Could you please share the following details in a support ticket?

  • Your keyboard model
  • Language configurations for your keyboard and macOS
  • Details of any apps that might affect keyboard input

2023 M2 MacBook Pro Keyboard.
Language UK English.
I have Logi Options installed for my MX Master 3 mouse, but could be using something for a Logitech MX Keyboard. Not used here.

The only other item attached is 3DConnexion Space Mouse.

Hey @HarrisonDavies,

We haven’t been able to replicate the issue so far. Could you please submit a support ticket through the following link for a more detailed discussion? Thank you!

Hi KPeter,

I’ve just checked and it’s now resolved. I did update the application last night.

Thanks for checking.