Multi faceted extrusions?


I’ve been using shapr for ages, but have come across an issue I have not seen before!
When I draw a circle or curve and then extrude it to make a solid shape the extrusion is not a smooth curve but a multi faceted thing!
Never seen it before yesterday, I went back over my previous drawings and they are all fine, if you zoom to 0.001mm you can see some faceting but my current drawing is visible at 1mm.
It’s like I’ve turned on a low res option.
Can anyone help?



Go to Settings in the app, and scroll down a bit at the General tab, you will find the Resolution and Anti-Aliasing settings. Here you can double check if the resolution is right.

If it is, and you still have this issue, please contact our support team and attach the project in .shapr format, we are happy to investigate.

Hi Laci,

Thanks for the reply, anti aliasing is set to 4x MSAA, and resolution is set all the way to the right.

As an update, after I messaged I moved the objects to align them and rotated them and some of the curves now look smooth, but some still look faceted.

I also exported the items to my 3d printer slicer and they are completely smooth even when zoomed in as far as possible?!

So its outputting correctly, just not displaying the items correctly?


Yes, it is only the visual representation, not the model that has issue. Are you by any chance modeling far from the origin?


No it was modelled near to the centre.

That’s interesting, what are your computer’s specs?

Also, do you have more bodies in this workspace? Maybe some far from this one?


I actually tried it on 3 different computers, Started on my home laptop, then picked it up on my 12.9 ipad pro, and now I’m at work on a different pc. All show the same result.

I did import a STL file to use as a template to take dimensions from.

The STL is also in the centre.

This pc is, Intel(R) Core™ i5-9500 CPU @ 3.00GHz 3.00 GHz, 32.0 GB RAM

Home laptop, is an i7, without looking I cant remember the spec, Ipad pro is less than 1 year old.

1 Like

Could you open a support ticket, and attach the problematic workspace in .shapr format, and if possible also the imported STL?

Will the shapr exported file contain the STL that I imported?

Its on my laptop, which is at home.

Yes, it will.

We took a look at the project, the issue is with the more than 800 imported meshes. We lower tessellation quality in complex projects for better performance, and visibility doesn’t affect this settings.

The solution is to delete the folder with the meshes, open another project, then go back to this one, the rendering quality will be fixed.

Perfect, thankyou, I did notice that the STL I imported was incredibly fragmented!

Not sure why!

Didn’t notice this until after I had the issue though.

Thanks for the help

1 Like