New Beveled Gear

The goal is to produce a beveled gear.
Using methods akin to the old gear tutorial a gear sketch has been made.
When trying to extrude at 45 degrees the app hangs with the screen dim and the Shapr3D logo animated until it times out without success.
Going at it a different way a copy of the initial sketch is made, scaled then moved over the initial sketch.
From there the Loft tool is invoked with the result that the app crashes.
From other graphic app testing on the iPad Pro this behaivior is a result of more operations than the iPad can handle.
Each sketch has 288 elements.
Is there a better way to create this object that I’m missing?

The fileBeveled Gear.shapr (2.6 MB)

This one will loft:

gear work up.shapr (1.5 MB)

Thanks for reporting the issue, it’s not the iPad Pro’s fault, but our implementation’s :slight_smile: We will tweak the loft algorithm a bit and it will work like a charm.

Aaaan it works :slight_smile:IMG_0090

I significantly reduced the sketch count in the following file and the loft worked more smoothly yielding something closer to what I’m looking for.

30 Tooth Gear Base Sketch.shapr (1.3 MB)

However when an extrusion is tried from the base sketch the extrude function fails. I’ll send the vid to

It will work with an arbitrary number of sketches with the next release :slight_smile: Thanks for the video.