Shapr3D randomly adding many control points

I made this sketch early on in the project, and I had it simple with a few control points. At some later stage, after making a complex model derived in part from this sketch, Shaper3D added about 100 control points to the splines. I can’t pinpoint the exact moment it happened, but if I had to guess I’d say maybe it was after a sketch projection. I manually went through and removed as many as I could, but I really can’t since much of the rest of the model needs this to be what it used to be. Is there any way to work around and remove all the unnecessary control points without changing the dimensions or do I just need to backtrack and lose all my work after this point? Also, if this is a known issue, how can I avoid Shaper3D doing this to my models. Also also, is it as bad of an idea as I think it is to continue on with these bodies having these many lines/faces? I feel like it will severely limit what I can do with the model and probably cause even more random problems to occur.

It looks like you made complex curves from a sketch, created an object out of it, then tried to re-project that object back into a sketch. For ~reasons~, Shapr doesn’t like re-projecting curves and I’ve seen this behavior a good number of times. Seems like Shapr is unsure of itself when putting complex curves back into sketch form, so it does what it can by adding in tons of individual sketch features to try and recreate it.

It’s a good idea to try and make complex curve sketches mostly one-way creation devices for this exact reason. Trying to get a useable sketch back out of an object that already has nonstandard curves in it is generally asking for trouble. I would advise getting creative with your order of operations as a workaround.

And yeah, I wouldn’t really want to work with the object spit out by that sketch. For one, you’re going to have a hell of a time making mass manipulations of any kind because your faces are going to be so segmented. Have fun with that. Beyond that, I could imagine trying to constantly render that many “separate” faces will cause undue processor load and maybe bog you down.

Wish I had a happier answer for you, but that’s an honest one. I wouldn’t try salvaging that.

E: Another helpful practice is to make “Golden Master” folders of important sketches or objects as you go along. Take what you want to preserve, create an entire copy of it inside a folder, name the folder “GM Sketches” or whatever, move all the contents to some random location in CAD space so you don’t accidentally trod on your other work, and hide it. Boom, you now have a living vault of known good pieces and sketches in your workspace in case anything randomly goofs just like this.

1 Like

Yeah thanks I decided to make a plane above, and replot the spline over top as accurately as possible and I’ll just spend some time manually cascading that through the rest of the model. I also notice a problem when offsetting an edge. There are 3 offsets in that sketch area. So I now have a nice simple spline and go to offset it. After the offset the new offset line is a lot more complex than the first. So I’m now spending the time to manually offset the new lines and lock them all down with the same number of control points measured and angled out correctly before moving on. It sure is taking a while to do that, but it looks so much better now.

1 Like

Well after doing all that work to lock down manually added control points to the manual spline offsets (to avoid Shapr3D adding a million controls points), I extruded the bodies and went on with life. Today I open the file to knock out some work and Shapr3D is once again adding a ton of control points. It took me more than half a day to cascade the manual changes through the rest of the model. I really am at a loss this program is killing me and it feels completely unreliable for actual work. Man that’s a lot of my time lost and I have deadlines.
tl;dr How do I stop Shapr3D from ‘randomly’ ruining my work?

It looks like I will NEED to use your idea of keeping a master sketch. Since I haven’t manipulated the current sketch Shapr3D has ruined again but it has actually been ruined again anyway I think a master sketch stored in the same file will not be good enough. I will have to keep master sketches stored in their own separate shaper files and just import them when needed (hopefully not every single time I open the file though, but at this point that seems about right.) Luckily I save a new project frequently now and was able to dig out the sketch before Shapr3D ruined it again. If I manage to get the project done despite these kinds of problems the worse thing will be that unfortunately I now have 0 confidence in the program.

Well, Shapr3D doesn’t only add a lot of extras to splines it seems; it’s happening to all kinds of sketches seemingly at random. This was a nice clean sketch until I needed to make an adjustment and looked closer at it.

How can I possibly stop Shapr3D from ruining my work like this?


I tiny simple sketch/extrusion is ruined by Shapr3D adding a bunch of control points and faces. Maybe the best thing is for me to try to get the most usable parts of my projects out of Shapr3D and into a different application that will not ruin them constantly. I just can’t see how it can’t even extrude a simple shape like this without wrecking it. What a let down that I’ve wasted so much of my time on this.


It was a simple sketch with minimal points. I projected it to a surface and Shapr3D adds all these extras. I guess there is a problem with projecting/offsetting/extruding from sketches in the app.

A workaround I’m doing now is to copy the sketch while moving it to the new location. It seems avoiding any kind of projection is the way to move forward as it seems EXTREMELY broken. Also extrusions can ruin the sketch they’re derived from, so best to make a copy of the sketch, move it out of the way, extrude from it, then move the body back into position. This way you let Shapr3D ruin the copy of the sketch instead of the original sketch, then delete the copy. At this point it may be helpful to keep a whiteboard on your desk to jot down all the bugs and workarounds in case you forget; you don’t want to waste days redoing things Shapr3D has broken like I have.

Yeah Shapr sees any sketches occupying the same plane as being part of the same sketch. So the trick is to copy-move the sketches you want as your GMs to a very slightly different location. Even offsetting by .005” will do the trick. As long as they don’t occupy the same physical plane your sketches will remain segregated. Then you can pull objects out of your GM sketches with ease, and the folders can remain hidden just below the surface.

I haven’t carefully read all the posts, but in my understanding this is “not Shapr”, but this is how it works in every CAD, due to the math behind these operations. If I understand correctly, the problem is that when you

  1. project a curve
  2. offset a curve

the resulting splines will have a ton of control points. This is expected, simply because projected and offset curves tend to be super complex (and often not even continuous!), thus you need very complex splines with a lot of control points to accurately represent them. This is a normal behavior. Projected and offseted curves are usually not edited in a modeling flow, thus this rarely causes any problems.

I may not be expressing the behavior well enough in the posts and images, or maybe this actually is Shapr working correctly. If I understand what you’re saying, I cannot expect to offset a spline withough Shapr adding many extra control points which pretty much ruins the spline from that point moving forward. Working with a spline with 100 controls points jammed together is not going to be useful, and extruding a body from that gives many faces which cannot be worked with as well. I also imagine this creates a lot of processing need. Also, that is only 1 of the problems I’m running into here. I have other sketches, image above, that were simple sketches consisting of some straight lines and splines. Shapr has broken up the simple straight lines into many lines as well as added a lot of points to the splines. Basically any time I need to move or transfer a sketch/sketch part, or extrude from a sketch, Shapr ruins the sketch. I KNOW this is not normal behavior in other CAD. This also seems like extremely ‘simple’ (I know it’s amazingly complex behind the scenes) functionality offered in the app. At least the ability to extrude bodies from sketches has been promoted a lot. If this is normal behavior there should be an asterisk in the promotions that say “*sketches are one time use if extruded from, offsetted, or projected”

Can you share a workspace where you experienced this behavior? A step by step reproduction would be very helpful to understand what’s going on. Unfortunately based on the images it’s very hard to tell what’s the problem.

Here is a ‘quick’ (12m) video showing some of the issues I’m running into. I tried to be quick and to the point(s). Near the end I show more issues with sketches I’ve been running into. Shapr3D Sketch Problem(s) - YouTube

I can share the workspace if it will help (not sure where to share to), but it seems to happen on pretty much all projects

I like your office set up. Nice assortment of Prusa 3D printers. :+1:
I have 3 printers, a Prusa MK3, a Prusa Mini and a Lulzbot TAZ6.

:slight_smile: Thanks! Yeah I’m new with the Prusas but man they are good! Even the MMU2S, although those sometimes are a bit picky. Have you done any mods to them? I have the nyloc nut mod on the MK3s and will do the silicon tube mod to the Minis soon.

No mods. I have a stock MK3 and Mini. They are great printers. I"m 2-1/2 years new to 3D printing. I use Shapr3D for designing prototypes and I mostly print with PETG and 3D-Fuel’s Pro PLA. The only mod I did was to the TAZ6. I added a magnetic removable bed (Wham-Bam) and a .4mm nozzle extruder for use with 1.75mm filaments. The TAZ comes stock with a .5mm nozzle and used 3mm filaments.

In a couple weeks when my shipment arrives I’ll see if an iPad Pro with more RAM will help with the problems. If that doesn’t help then I don’t know what else to do other than transfer to a different CAD software. I still can’t believe Shapr3D has this much trouble with ‘simple’ sketches as sketches are the starting point for projects. I MUST be doing something wrong. Can anyone see anything I’m doing wrong? Am I expecting the software to work in a way it isn’t meant to? Any ideas to combat this? The only thing I can think of right now would be to just consider sketches single-use items since they are unreliable/randomly changed after a short while.