One body multiple faces

I created a body but it has multiple sections on its top and bottom faces…sides are all one face. How do i eliminate these lines on the top and bottom face? And how do i avoid creating them in the first place.

You can’t. In boundary representation ( usually edges are connecting two non-continuous surfaces. If you don’t wan’t to have those edges there, you have to create your model in a way that the surface on the top would be a single surface.
In your case I assume the curve on the top of the side profile is created from several different curves. If you replace those curves with a single curve, the extruded body will not have those edges.

But usually this doesn’t matter, why do you want to remove the edges?

I brought up this issue ages ago.

One good reason is aesthetics — they look ugly! And when showing a design to anyone - they ask, “What are those ugly lines for?” That’s why…



Does it help if you turn off edges in Shapr3D screenshot?


Exactly as @kaiaho says. Or you can use the built in AR viewer as well.


Thanks for your answer. I am trying to project outsole lines on the bottom of the object and that works but when i go to use the extruder to push those line in by 1mm to represent the tread of the outsole in my work… it breaks up the lines at each edge and won’t allow a continuous groove to be created for the tread.

Thanks … this helps … because one problem was the esthetics.

1 Like