Shapr3D 3.0 is here - and it’s changing the CAD landscape

TLDR; Shapr3D 3.0 is here and it is based on Parasolid ®, that is the CAD engine that fuels Solidworks and most of the active CAD seats. This elevates the product to a new level, especially that it’s still just $150/year - not thousands of dollars, and still super easy to use.

Hi there Shapers,

Today is the day of the BIG LAUNCH, the public announcement of Shapr3D 3.0 - a new version of our app, that not only elevates Shapr to the next level, but also changes the CAD game. Why is that? In one word: Parasolid. If you are a CAD junkie, then now you will start screaming, and running around in little circles, but if you are not, let me put this into context.

Our story started in 2014, when I put together the first prototype of Shapr3D. No, you didn’t misread it - it was in 2014, when there were only rumors about the iPad Pro, and I expected it to be released in late 2014. Well, it happened a bit later, but finally in 2015 Apple unleashed the first iPad Pro, the first iPad that was designed for content production, not for content consumption. 3 months after the announcement of the first iPad Pro, we released Shapr3D, and it started to take off, despite it was super simple, and it only had 10% of its current feature set (and of course we are still not done). Most of our users saw its potential, and even with that very limited the first version - that had tons of bugs and awkward UX fuckups - started to create amazing things.

As every CAD system, Shapr3D is based on a geometric modeling kernel (GMK), that is basically the heart and soul of a modeling environment. GMKs are special kind of animals, there are very few on the market, and there is only one that is open source and freely accessible: OpenCASCADE. This was the reason why I decided to go with it: since it was open source, I could port it to iOS, and it was good enough to start the development of Shapr with it. Unfortunately we quickly reached its limits: despite working fairly well, it does have lots of limitations and lacks quite a few features. In order to make a step forward we had to replace OpenCASCADE. And since we are pretty ambitious, we couldn’t go with anything else, but the best GMK on planet Earth: Parasolid® by Siemens PLM. Parasolid® is the Holy Grail of the CAD industry. It’s been under development for 30 years, and it is by far the most robust and mature modeling technology on the market. It is the technology that fuels Solidworks, Siemens NX, SolidEdge, and many other 3D CAD systems. Look around you: if you see something that was designed in a CAD system, there is a very high probability that it was processed with Parasolid® at some point in the design and manufacturing flow.
But there was a tiny little problem: Parasolid® did not support iOS 12 months ago. So we started to work with Siemens to make the impossible happen: run the world’s most advanced CAD engine on a mobile device. After 10 months of hard work, I am happy to let you know: Shapr3D is now running on Parasolid®, and its performance is incredible, desktop grade - or even better. This has been a long journey, and we’ve basically rewritten Shapr3D from scratch, but the end result is pretty impressive: a super-easy-to-use, yet professional, full-featured direct modeling system on your iPad Pro.

From now on, we will release new versions every 2-3 weeks, as we did it until 10 months ago, when we started to work on this huge update. You can expect lots of improvements and new features every single month - and as always, we would love to hear about you, let us know what you think, and what you would like to see in the app.

Together with this big release, we have been working on another big thing: closing our next fundraising round. I am happy to let you know that Shapr3D has just raised $1.3M from top-tier investors. The round was led by the most amazing Roberto Bonanzinga (formerly GP at Balderton Capital/Benchmark Europe) from InReach Ventures, with the participation of Lifeline Ventures, Kima Ventures, and top notch angel investors. We are incredibly proud that such amazing people decided to join our company, and we are looking forward to (re)build the CAD industry with them.

Not surprisingly we are hiring like crazy, so if you are interested in joining us, take a look at our job openings page:

Ps.: here are just a some of the improvements and new features you will find in 3.0:

  1. Direct modeling features: move faces and parts of shapes, change and remove blends, change, move or delete any geometry, even on imported models
  2. Face replace tool
  3. Improved revolve tool with support for helical bodies
  4. New workspace manager
  5. X_T (Parasolid) import and export
  6. Improved STP and IGES import and export thanks to Techsoft3D’s industry standard HOOPS exchange library
  7. Better support for STL export
  8. Improved rendering performance
  9. Improved constraints solver
  10. Thanks to Parasolid, all the modeling tools are now super robust and stable: shell, loft, boolean subtract, intersect and union, replace face (new tool!), direct modeling operations, revolve, sweep etc.
  11. Construction geometry, construction plane and construction axis
  12. Brand new knowledgebase and documentation
  13. Free trial - try all the Pro features for free for 2 weeks
  14. Improved sketching flow

And many more.

We were trying to make this transition as seamless as possible, but as any huge update for any software product, it inevitable caused some problems - sorry about that. We have already released 3.0.1, that fixes most of the issues you might have experienced. We hope you will enjoy this new version. Happy modeling!


Founder & CEO of Shapr3D


I had gone away from Shapr3D for a while. My work had me going to Fusion 3D to do more detailed modeling. I’m turning back to Shapr3D now to try out the new upgrades. The thing that’s striking me the strongest is that I’m having quite a hard time sketching. It seems like the inference engine is making very unintuitive guesses.

For example, if I draw a line straight up and down, then try to draw a line starting midway alone the line, I’m unable to make it come out perpendicular. Rather it skews off at an odd angle and I have to go in and put constraints on it to make it perpendicular. Drawing an arc tangent to a line is even harder. I have to draw the line, then have an arc come off it. Then constrain the heck out of the line and finally set perpendicularity. Anything short of that has the arc and line jumping all over the place.

Is this all related to the new engine?


Hi, no it’s not. If you have a problematic file or an example for the issue, please create a topic in here:

Super hyped to know that new features are going to be added on the monthly basis. So cool.

As per new features, is the following a possibility:

  • Being able to render with textures
  • Contruct animation like in fusion 360

I do understand these are massive features which would take forever, but it would really add to the already awesome App.

I know I am just listing features from desktop CAD softwares. But it would really be a dream come true…

There would be one thing which would really help with Product Design and Development…

  • Undo option per part and sketch created. So let me explain. If I created a Part or sketch right at the beginning. So after having finnished the whole design which took 2-3 hours, It would be great that I could undo a process that I applied to that part that I altered in the beginning…as it would be impossible to undo all the way back…and also undesirable.

Please let me know, if the last feature I listed is something that could possibly be intergrated. Would help so much.

Thank you for your time.

Not sure how we missed this!
Well done all :blush:


Excuse me but the shell function sometimes works well and sometimes not and this can be very persistent, I have closed and restarted and tried in a new file on a simple cube, in vain. The result is like a shell with zero thickness, a kind of surface. And then suddenly it works back. it doesn’t seem that stable to me!
I respond so late because I have only started with Shapr3D for a few weeks.

Hi - can you please send a video (and workspace) to and we will investigate the issue.

I have no control over it and currently it works normally again. When the problem arises I will contact you again. I suspect, but I am absolutely not sure, that it started after importing a stp file (from uMake). In fact, these are meshes and not solids and it is therefore impossible to apply such edits to them (although I sometimes manage to get a boolean substract, not understanding when it works and when it fails). But the odd thing is that I ran the shell on a solid created with Shapr3D within this imported file. Even when I tested on a cube in a new file, the problem did not disappear, nor after restarting Shapr3D. In the meantime I have reinstalled the app and it is currently working again. But I will try to reproduce the problem. Do you think it could be the cause?

Unfortunately uMake generates very low quality geometry, so it’s absolutely possible that this is causing the issue.

I think I have traced the cause of the problem. For an unknown reason to me, the scale in uMake was set incorrectly so that the object, imported into Shapr3D, touched the boundaries of the workspace. I have been able to reproduce this, although it took a lot of effort (not only to change the units but also to make the object many times larger) so that I could not have done this intentionally. The strange thing about uMake is that if you change the units, for example mm to cm, 100 mm is converted to 100 cm. So not like with Shapr3D where the dimensions of the object do not change, which cannot lead to confusion.
Now it works normally again and if I have bothered you with it while the fault was not with Shapr3D, I apologize here.