Shapr3D on new M4 iPad with Pencil Pro

Hi guys,

Just got a new M4 iPad Pro with Apple Pencil Pro today and couldn’t get Shapr3D to work with the Pencil Pro. It seems that it is not recognized by the software. Hope you can fix this with the next update. Thank you very much!

Best Regards,
Michael

3 Likes

Thanks, we’ll look into this.

Not sure if it is the same problem, but on mine it seems to actually work fine, but every time the tip of the pencil is moved away from the iPad (more than “hover” distance) I get a Red “Apple Pencil not connected” popup. Disconcerting, but it immediately reconnects as soon as the pencil is close to the tablet and as far as I can tell, all touch and hover functions are normal…

2 Likes

I had this same issue and managed to figure it out.

I also have the Magic Keyboard, I attached this and Shapr asked me if I wanted to change the control method to keyboard. I said yes, used the pencil with the keyboard attached then removed the keyboard and the pencil worked fine.

I’m assuming this will work with a Bluetooth keyboard as you only need to trigger the change in control method.

*note: I did a clone of my iPad 2018 to my iPad M4. I’m wondering if there’s a .plist error for the pencil in the settings when I transferred. Would be useful to know if you set up the M4 as a new device or a clone.

Hope this helps.

1 Like

I had this issue this morning after also restoring a 2018 iPad Pro backup to the new M4 Pro.

After opening a design it wouldn’t let me open the editor until I attached my Pencil (suggesting Shapr3d isn’t seeing any pencil because it’s only looking for specific Pencil models perhaps?) - but closing the design, reopening and hitting “skip” in each dialog that came up it worked fine, and other than the newly announced features (obviously) missing from Shapr3d with the Pencil Pro, it seems to be working fine…

I am having the same issue

1 Like

I’m having problems, too. I keep getting a “pencil not connected” message intermittently; sometimes I can draw, at other times I can’t.

1 Like

I am having a similar issue. Keeps flashing Pencil not connected. I can use my pencil but the second it gets more than an inch off the screen it looses connection to the apple pencil pro. Also new ipadpro m4

1 Like

Can anyone say if the previous Apple Pencil will work with the new iPad Pro 13” without issues?

I have the new iPad Pro ordered and should have it next week. I’m not swayed enough by the new Pencil Pro frills to buy one, especially now that some of you are having some issues with it. So for now I’d be happy to plod along with my current Apple Pencil, if it will work with the new iPad.

@Stephen

According to Apple, the older pencils will not work with the newer models because the charging circuitry and attachment magnets had to be reconfigured because the FaceTime camera (and FaceID on the Pro) was moved from the short side (top in portrait mode) to the long side (top in landscape mode.

Also the “squeeze menu” is really nice in Apple Notes, etc. and I hope Shapr3D will choose to support it in the future.

1 Like

I am having the same issues, I tried some hints that were suggested here but no luck so far.

Same issue here. The pencil is actually always connected and I can draw but the message pops whenever I stop drawing and goes away whenever I start again.

Everyone will have this issue, because the Apple Pencil got renamed to Apple Pencil Pro. Besides the error message it shouldn’t cause a problem, and a fix is coming soon.
Our M4 iPads are arriving this week.

3 Likes

Thanks for that info Steve. Looks like I’ll be purchasing the new Pencil after all.

Pls. Share a big thank you to the dev’s for the latest release with the Apple Pencil pro fix… it’s been working great!

2 Likes