Sketch disappears


I used shapr3d in the past and there is a difference in how you extrude from sketches now that is really annoying.

I like drawing things first and in the end proceed with extruding the areas. However, if I draw the sketch and start extruding, if I only extrude one of the areas the remaining areas and sketch that were not extruded simply disappear and I have to sketch everything again.

What am I doing wrong?

I tried attaching a video but since I am a new user to this forum it doesn’t allow me to.

That’s the way the new HBPM works it hides the sketch, just go into items and click the eyeball icon next to the sketch. If you update to the latest (iirc 5.621) it will only hide after you use all the elements, it can be unhidden the same way.

Hmm. Yes you are right. It’s just not user friendly.
Yesterday I gave up sketching 20 patterned circles. It says there’s a conflicted constraint. After an hour looking for what could be wrong, started a new file, drew 1 big circle, a smaller circle on top of which I drew a smaller one and tried the pattern. Still the constraint issue comes up and deletes the pattern sketch.

The previous versions of shapr3d were much more user friendly. I am strugling with this one. Still my favorite 3D software but…

With the next release we’ll hide the sketch only if it’s fully consumed by the subsequent 3D operation.


I’ve had similar issue, draw a line and all of a sudden it’s fully constrained though it’s not to any other points/nodes nor did I add any constraints to it. Now I find myself specifically drawing at slight angles then defining as I need, it’s a bit backwards.