Snap to grid - always off grid

Hey!, so this has been an issue for me for as long as I can remember but now it’s becoming really difficult to work as I’m building precise modular parts.

When I activate snap to grid, it doesn’t usually truly snap to grid, it’s always a tiny bit off and the more I duplicate the worse it gets. Floating point error?.

I’m not able to get line actually on grid. Generally I can duplicate 1 or 2 times if I’m lucky, then it’s totally off grid. Attached image ( video wouldn’t upload)

I have tried with and without guides. With guides usually makes it even worse. Is there a setting I’m missing, I never seem to be able to get precise sketches. Possibly I’m doing something wrong?.

When building many pieces together and then realizing everything is slightly off is devastating lol… happens every time. :frowning:

This is not an answer to your problem, but hopefully useful.

Are you working zoomed in, without reference to the grid size difficult to tell.
Is the Dimension shown 1.6"?
When zoomed in I find Snapping [everything switched on] less precise.

I work in Metric and with the Grid set to 10mm everything Snaps perfectly.
You could temporarily set up the Grid similarly to see if there is any improvement, or adjust your appropriately?

Hey!, how do I change grid size or know if I’m too zoomed in. The detail level was around 1,6 inches. Which isn’t super small. I’d expect it at the mm level but not inches :frowning:

The 1.6" dimension limits were not visible on the screen, suggesting zoomed in.

Tap the # ??" [whatever it is set to, or in my case it is # 10mm]
In the DropDown ensure the Grid ids NOT locked at that setting.
Use the Two Finger [thumb+ finger] Gesture to Squeeze Inward to Increase the Grid Size, Stretch apart to do the opposite.
Temporarily switch to metric if that helps to get an feel/idea of the sizing.

Oh wow haha, didn’t know that was a drop down lol. Cool, glad I can set to something other than inches. Didn’t fix the problem. But helped in a different way :slight_smile:

In my case with the 10mm Grid and upward sizes the Snap is pretty ‘snappy’, no ‘hit n miss’ nonsense.
Sometimes switching off the Grid to Select a Line End, positioned Off Grid, often seems to have little effect with the Cursor jumping as if still being directed to hit the Grid.

I assume you have set it to a much larger Grid Size, checked that the Apple Pencil is fully charged and that you have the latest version of S3D.
When checking for S3D look under Version History to ensure that you have the latest version.
Often the App Store indicates that you should Open S3D while in reality there may be an Update available. Experience has shown after looking up the Version History hitting the Back button often reveals an update.

If nothing here helps then perhaps it is time to eMail the S3D Team?

Hi Max, do you notice this after you have drawn the lines or while you are drawing the lines some of the lines do not just align with the grid?
Can you also try to toggle on Auto-Constraint let’s see if this helps somehow?

If the issue persists please post a short screen recording showing the issue as this will help our investigation.

@MaxRobotnick I had a similar graphical issue once and I just uninstalled and reinstalled the app and that took care of it. I would suggest that.

Hey victor it’s after drawing. So the first line is snapped to grid but when I duplicate it skips grid lines when make copies. I made a recording but the forum won’t let me upload it. What’s the max format for uploading video?

Thanks for the response. You should be able to upload the video now.