Snap to grid won’t turn off

I have turned off snap to grid in the pop up menu at the bottom but it is still functioning.
When I move sketches I can’t place them accurately because they are snapping out of position.

Can I disable the snap to grid any other way so that it is actually turned off?

If you have not done so already, while awaiting further help, it may be worth trying closing S3D as per Apple directions;

Alternatively Power Off your iPad and then try again.

Experience has lead to closing all Apps properly at the end of each session, may be worth consideration?

1 Like

Can you send a video please, and a workspace if possible - either here or to - I’ll take a look - it should work